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About this manual 

1  About this manual 

1.1 Overview 
This manual gives you instructions on how to use the MCSize sizing tool. The main 
principles of operation are also explained. The manual is targeted to machine 
designers and anyone who needs to select electrical drive system components or 
wants learn how to select them. The manual is also available as an online help file.    

 

 

 
 



9 

About this manual 

1.2 Document conventions 
The following table lists the terms and conventions used in this manual. 

Table 1. Terms, conventions and abbreviations used in this manual 

Term or abbreviation Explanation 

Sizing, dimensioning Calculation of the correct size of the 
parts in a frequency converter assembly 

IC International Cooling 

IP International Protection 

RMS Root mean squared 

 

 



10 

Overview of MCSize 

2 Overview of MCSize 

2.1 General 
The name MCSize refers to motion control and machinery drives and the MCSize 
software is meant to be a fast technical computing tool for all users who need to 
select electrical drive system components. Typically a sizing process starts from the 
selection of mechanics and motion profiles. Also gears are an essential part of the 
system. Because the automatic gear ratio optimization is not currently included in 
the software, users are expected to use their common knowledge when setting the 
gear ratios, since it is an important part of cost effective solutions. 

The motor selection is based on technical facts only, usually on the torque 
requirements of the motion and mechanics. MCSize does not contain cost or price 
information and, thus, cost optimizing has to be performed manually. After the 
calculation of choices the frequency converter – also called drive – is then selected 
on the basis of motor current function.  

The single drive selections and the sizing of line converter with one or several 
inverters are supported. MCSize is a part of the DriveSize system and inherits the 
same principles. To help new users MCSize inserts reasonable default values to 
the required input fields. This way the users are able to command the software to 
dimension the motors and drives right away. The software for example gives the 
default value of 0.2 m for the driver roller of the conveyor, as a value of 0 m would 
cause the software to give unnecessary error messages about missing data. 
However, it is easy to override the default values and save new values for future 
use. In any case, an inexperienced user should read all inputs through before 
making any decisions. 

In addition, MCSize provides plenty of intermediate results for users. This helps the 
user to: 

1. double-check results 

2. easily find good and cost-effective solutions 

3. use some of the computed data when the drive or motor is started and 
commissioned with mechanics. 

MCSize requires DriveSize 2.7 or a newer version to be installed on the computer. 
DriveSize also contains the induction motor database. MCSize itself contains the 
servomotor and frequency converter databases.  

MCSize has been tested with the Windows 2000 and Windows XP operating 
systems. 

2.2 Functions 
With MCSize you can: 

·  Compute Torque requirements for various mechanical arrangements 
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·  Compare gearing alternatives 

·  Select the correct size of a drive and the correct motor combination 

·  Select a suitable line converter for the regenerative drive system  

·  Compute the proper braking chopper and resistor 

·  Compute multiple axis systems 

·  Export the produced results from MCSize to the .xls format. 

2.3 MCSize user interface 

2.3.1 Main window 

After you have opened or created a project, the main window opens. You can see 
the layout of the main window in Figure 1.  

 

System 
configuration 

Input data and 
specifications 

Selected data 
and results 

 

Figure 1. MCSize main window 

 



12 

Overview of MCSize 

Transformers, line converters, drives, motors, reductions, and motion profiles and 
mechanics all have their own data input displays. When you click on an item in the 
System configuration  tree, the input data display will change accordingly. 

2.3.2 Toolbar 

The toolbar provides quick access to common functions in MCSize. You can find 
the functions of the toolbar also in the main menu (see Table 2). 

Tip:  When you move the cursor over a button the help text for that button appears 
below it. 

Table 2. Toolbar icons  

Icon Action Menu equivalent 

 
Opens a new project File > New  

 
Opens a project File > Open  

 
Saves the project File > Save  

 
Opens the Print  dialog File > Print  

 
Opens the Ambient 
Conditions  display 

Data > Ambient Condition   

 
Opens the Motion profiles 
display 

Data >Motion Profile  

 
Opens the Network Check  
display 

Tools > Network Check   

 
Dimensions the selected item Tools > Dimension Unit   

 
Opens the dimensioning 
Results display 

Result > Dimensioning Result   

 
Opens the Graph  display Result > Graphs   

 
Opens the List selected  
display 

Result > Units Selected  

 
Opens the User Selection  
display 

Tools > User Selection   

 

In the upper right corner of the main window you can see the ambient conditions 
display. The displayed ambient conditions data are described in Table 3. 

 

Table 3. Ambient conditions on the toolbar 

Picture  Description  

 
Indicates the transformer’s 
ambient temperature 

 
Indicates the drive’s ambient 
temperature 
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Indicates the motor’s ambient 
temperature 

 
Indicates the installation’s altitude 
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3 Installing MCSize 

3.1 System requirements 
To run MCSize, you must have DriveSize installed on your computer. For system 
requirements, refer to the DriveSize manual. Additionally MS .NET Framework 1.1 
or later is required. 

 

3.2 Installation 

To start the installation of MCSize: 

1. Start Windows. 

2. Insert the MCSize CD into the appropriate drive or download the setup 
package to your local hard disk. 

3. Select Run from the Start  menu. 

4. Type the drive letter of the drive followed by “:\MCSize.exe ”, for example 
C:\MCSize.exe. Click OK or press ENTER. 

5. Follow the instructions the installation program gives you. 

The software installation copies all the necessary files to the drive and directory 
specified by the user. The setup program prompts you to install the software to 
C:\ProgramFiles\DriveWare\DriveSize . You can change the directory, if 
necessary. The set-up program also creates a working directory in 
C:\ProgramFiles\DriveWare\DriveSize\Projects  where all of your projects will be 
stored. 

If you have problems installing MCSize, close any other active programs. Restart 
Windows and do not open any programs before the installation is completed. 
Always disable MCAfee Host Intrusion Prevention System (HIPS) both while 
installing and uninstalling. 

Before reinstalling, uninstall the old version of MCSize. 

3.3 Uninstalling 
To uninstall MCSize: 

1. Select Start > Settings > Control panel . 

2. Double click Add or remove programs . 

3. Select the MCSize software from the list and click Remove . 
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4 Starting a project 

4.1 Opening new project 
In the DriveSize Welcome  screen, double click the ACSM1 Drives (MCSize) icon or 
click Open from the New project selection tab (See Figure 2). 

 

 

Figure 2. DriveSize Welcome window 

 

On the tabs Existing  and Recent  you can open projects saved earlier.  
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First Drive Type  dialog opens for a start. Select the type of drive you want to start 
with. There is possibility to add single drives and regenerative drives to the same 
project. It is possible to convert single drive to line converter supplied unit too.   

 

 

Figure 3. First Drive Type dialog box 

4.1.1 Changing project information 

To open the Project information  window (see Figure 4), select File > Project 
Info... .  

Enter new project data. MCSize saves this information when you save your project 
and includes it in your reports. Click OK to save the project information or Cancel to 
discard the changes. 

 
Figure 4. Project information window 
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4.1.2 Selecting ambient conditions 

To open the Ambient conditions  dialog (see Figure 5), click the toolbar icon  or 
select Data > Ambient Condition . 

Type new data to the appropriate text boxes to change the ambient conditions. The 
practical range for altitude is between 1000m and 4000m. 

Note: The altitude's dependency to the load capacity is different with different 
components. The practical range of ambient temperature is usually from 30°C to 
50°C. This also changes according to the component. For example, a temperature 
up to 55°C is acceptable for ACSM1 drives. 

Click OK to save the ambient conditions information or Cancel  to discard the 
changes. 

 

 

Figure 5. Ambient conditions window 

4.2 Creating new project file 
To create a new project file, use one of the following three methods: 

·  Click the toolbar icon  

·  Select File > New from the menu, or 

·  Press the Ctrl+N  short cut key 

The name of any new project file is "Untitled" until you change it. You can change 
the project name when you save the project. 

4.3 Saving project file 
To save the project file: 

1. Click the  icon, or Select File > Save . 
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2. For new projects select a location and type in a name for the project. 

4.4 Opening saved project 
To open a saved project: 

1. Click the  icon or select File > Open . 

2. Select the project file and click OK. 

The ACSM1 motion control project files have a unique file extension. Select the 
correct extension option (.mdd) from the List of file Types to open these files. 
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5 Sizing 

5.1 Sizing procedure overview 

5.1.1 System configuration tree 

The System configuration tree displays an overview of the frequency converter 
system as well as the type designations or names of units in the tree format (see 
Figure 6). MCSize includes different data input displays for the transformer, supply, 
drive, motor, gearings, and motion profile and mechanics data. When you click on 
an item in the System configuration  tree, the input data display will change 
accordingly. 

 

 

Figure 6. System configuration tree  

 
The System configuration  tree includes the following icons: 

 Transformer 

 Supply (when regenerative drive) 

 Drive 

 Motor 

 Gearing  

 Motion profile and mechanics 
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5.1.2 Order of selections 

Dimensioning selections can be performed for example in the following logical 
order: 

1. Select a Secondary voltage [V]  for the system. 

2. Select the Frequency [Hz]  setting. 

3. Select the type of application. 

4. Enter motion profile input data. 

5. Specify application data for mechanics. 

6. Select gearings and enter input data. 

7. Select motor specifications and motor sizing. 

8. Select drive specifications and sizing. 

9. Select supply specifications and sizing (when regenerative drive) 

 

To add a second axis, select Insert >  Drive + Motor +Mechanics  or Insert >  Supply +  
Drive + Motor +Mechanics from the menu bar and repeat the selections from 3 to 9.   

 

However, MCSize allows you to select and modify units at any level, and you can perform 
the dimensioning selections in any order. For example, you can easily change the supply 
voltage and frequency at any stage.  

5.2 Transformer data 

5.2.1 Entering transformer data 

To modify transformer input data, open the transformer display (see Figure 7) by 
selecting the Transformer  icon from the System configuration  tree. 

To modify transformer data: 

1. Select the Secondary voltage [V]  setting from the drop-down list.    

2. The default Frequency [Hz]  setting is 50Hz but you can change it to 60Hz if 
valid. 

3. MCSize also displays the Calculated load power [kVA] , which you may 
override by typing a value for Load power  [kVA] . This will affect the 
transformer selection. 
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Figure 7. Transformer load data definition 

 

5.2.2 Modifying transformer specifications 

Insert data in the Specification  field of the Transformer  load  display. 

You can see the input fields for transformer load specifications in Table 4. 

 

 

Table 4. Transformer load specifications 

Specification Options 

Name Any text or number string. This will also 
show up in reports and, depending on 
the Tools /Options  settings, on screen. 

Type Dry, Oil 
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5.3 Supply input data 
To enter supply load data, open the Supply load display (see Figure 8) by clicking the 
Supply icon in the System configuration tree.  

 

5.3.1 Profile type 

Two Profile type  options are available. One for Manual  load entering and another 
for Derived  load. Derived load means that load is calculated  based on mechanics 
connected to that regenerative supply unit. The loads that have identical cycle time 
are collected to own groups. It is also possible to define phase shift between loads 
with same cycle time (see Figure 8).    

 

 

 

Figure 8. Supply data definition 
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Figure 9. Manual supply data definition 

Select manual profile option to enter load manually. These inputs override the load 
calculated on mechanical load. When manual profile is selected then Supply Unit 
Profile  view opens (see Figure 9). 

 

Manual can consists on up to 50 load points.     

5.3.2 Modifying supply specifications 

You can set the following specifications for the regenerative supply: Line converter 
amount, type, line filter, IP class and switching frequency. To modify drive 
specifications, click on the desired item. Select new values from the drop-down lists 
or type the new value to the field. 

 

You can see the input fields for drive load specifications in Table 5. 

 



24 

Sizing 

Table 5. Supply unit load specifications 

Specification Options 

Name Any text or number string. This will also 
show up in reports and, depending on 
the Tools /Options  settings, on screen. 

Supply amount Number of similar drives with range 1 – 
100 for one branch in the System 
configuration  tree 

Type Air cooled, Cold plate 

Line filter Included 

IP class Not specified 

IP20 – This selection means that the 
user is specifically limiting the choices 
to the IP20 protection class. 

Switching frequency 3, 4, 5, 8 or 16 kHz 

 

5.4 Drive input data 
 

5.4.1 Entering drive load data 

To enter drive load data, open the Drive load  display (see Figure 10) by clicking 
the Drive icon  in the System configuration  tree. White fields are editable and 
grey fields are calculated on the basis of profile, mechanics, gearings, and motor 
input data. The calculated values include primarily dimensioning criteria. However, 
drive load inputs are optional and they override the calculated values.  

The inverter is loaded with the calculated motor currents, frequency and power 
factor.  

You can change the motor currents. Enter new values to editable fields for each 
segment. These values override the calculated values. Note that all the other motor 
data and the given speed profile will still be used. In Table 6 you can see the 
explanations of abbreviations that are used on the display. 

 

Table 6. Explanation of abbreviations in Drive load display settings 

Abbreviation Meaning 

RMS-current Root mean squared value for the whole 
duty cycle currents 

Max-current The calculated peak value that occurs 
during the duty cycle 
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5.4.2 More complicated inverter profile  

The text custom  is shown in Drive load display’s current and duration fields when 
the Duty type of motion profile is Multiform cyclic. Open Inverter profile  to see the 
segmental currents. You can also enter the new current for each segment and 
these values override the calculated values. All the other motor data and the given 
speed profile will still be used. 

Click the  icon, or select Data > Motion profile from the menu to open Inverter 
profile.  

 
Figure 10. Drive load input data 

 

5.4.3 Modifying drive specifications 

You can set the following specifications for the drive: the inverter amount, type, IP 
class, switching frequency, braking chopper and resistor.  
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To modify drive specifications, click on the desired item. Select new values from the 
drop-down lists or type the new value to the field. 

You can see the input fields for drive load specifications in Table 7. 

Table 7. Drive load specifications 

Specification Options 

Name Any text or number string. This will also 
show up in reports and, depending on 
the Tools /Options  settings, on screen. 

Inverter amount Number of similar drives with range 1 – 
100 for one branch in the System 
configuration  tree 

Type Air cooled, Cold plate 

IP class Not specified 

IP20 – This selection means that the 
user is specifically limiting the choices 
to the IP20 protection class. 

Switching frequency 4, 8, 16 kHz. Higher switching 
frequency will reduce the audible noise 
and give better motor performance, but 
will adversely cause losses in the drive 
and the max current providing 
capability.  

Braking chopper Ignored – This selection means that 
even though the internal chopper is 
used, the losses of it are anyway 
ignored when a drive selection is 
performed.  

Internal – This selection means that the 
losses of internal chopper are added to 
drive losses and the limitations of the 
internal chopper are considered when 
selecting a drive.  

Braking resistor Not considered – The braking resistor is 
not selected this time.  

Selected – The braking resistor is 
selected on the basis of the motion duty 
braking power requirements. 
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5.5 Motor input data 

5.5.1 Entering motor load data 

Open the Motor load  display (see Figure 11) by clicking the Motor  icon in the 
System configuration  tree. The calculated values are shown in grey fields. To 
enter optional motor load data, fill in at least one value. 

 

 

Figure 11. Motor load input data 

 

Input fields are editable and calculated values are based on profile, mechanics and 
gearings. The calculated values include primarily dimensioning criteria, but motor 
load inputs are optional and they override the calculated values. The calculated 
torque is a peak torque at motor shaft and in the final results the motor inertia is 
also taken into account. The calculated speed is the speed at the max dynamical 
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power or the speed when the calculated peak torque really exists. Only the 
quadrants that really exist in the mechanical application are shown in the motor 
input load view. You can see the definitions of quadrants in Table 8. 

Table 8. The definition of quadrants 

Quadrant Description 

Q1 Positive torque, positive speed 
Q2 Negative torque, positive speed 
Q3 Negative torque, negative speed 
Q4 Positive torque, negative speed 

 

5.5.2 Modifying motor load specifications 

You can see the input fields for motor load specifications in Table 9. Note that some 
of the input fields are dependent on the selection made in the Motor type field. 

Table 9. Motor load specifications 

Specification Options 

Name Any text or string 
Motor type ServoMotor – Permanent magnet servo 

motors in database,  
InductionMotor – ABB's catalog induction 
motor,  
ExistingServoMotor – Enter motor 
characteristics case-by-case,  
ExistingInductionMotor – Enter induction 
motor characteristics.  
UserDefinedServoMotors 

Motors per inverter Normally 1, but can be in the range 1 – 
100 similar motors per an inverter unit.   
The load is given for one motor. One 
inverter feeds several motors connected 
in parallel. 

Family According to the Motor type  selection, 
the motor family choices are shown. If 
you have no preferences, use “Not 
specified”. 

Polenumber Not specified, 2, 4, 6, 8, 10, 12 
Feedback type Not specified, Encoder, Resolver 

– With servomotors an encoder motor 
might give less output than a resolver 
motor because resolver motors 
withstands higher temperatures. 

Max inertia ratio Not specified, 2, 3, 4, 10, 100. Read the 
text below this table.  
 

Temp rise class Not specified, B [< 80K], F [<105K]. Not 
specified  means that MCSize will use 
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the class given in motor catalogs. 
IC Class Not specified, IC-0041, IC411, IC416. 

IC-0041 = enclosed motor without 
cooling fan. 
IC411 = cooling fan on motor shaft; 
means lower loadability at partial 
speeds. 
IC416 = separate cooling fan. Choose 
this option for constant torque cases 
where the min speed is very low.  
For large motors there are other choices 
available. 

Size If specified, limits the selection to the 
particular shaft height of induction motor 
or the size code of servomotor. 

Auxiliary brake No brake, Holding 
Affects to the inertia of motor  

Max speed rule Standard, Metal fan 
Available only for Induction Motors 

Motor Tmax margin 43%, 20% 
Available only for Induction Motors 

 

In inertia calculations, the inertia ratio corresponds to the reflected inertia divided by 
the motor inertia. You can set the maximum acceptable value for this ratio. The 
ratio will be the motor selection criterion. The ideal ratio for reflected inertia to motor 
inertia is 1:1, a ratio that yields the best positioning and accuracy. The reflected 
inertia should not exceed the motor inertia more than tenfold, if it is important to 
maintain the control performance. 

Motor selection criteria are also based on system voltage which is given as the 
Supply voltage, Frequency and Switching frequency  of the drive.    

Catalog induction motors will have the same nominal frequency as the supply, and 
a nominal voltage similar to the system voltage. The switching frequency of a drive 
does not affect the thermal behavior of a motor within MCSize. The output voltage 
of a drive at a field weakening area is less than the system voltage, and this is 
taken into account when the maximum short term torque curve is drawn. You will 
notice this from the fact that the turning point of the curve is not exactly at the level 
of nominal frequency but below it.  

 

On the other hand, the permanent magnet servomotors have non-standard nominal 
voltages and they are always lower than the system voltage. When overloaded at 
higher speeds, the motor voltage will be higher than the nominal voltage but 
anyhow lower than the system voltage. Some reserve voltage has to be available 
for the good performance of drives. The nominal values of servomotors are given 
with a switching frequency included in the database. If the setting of drive switching 
frequency is lower, the nominal values of servomotors must be scaled down. If the 
drive switching frequency is higher than the motor’s switching frequency, the 
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motor's nominal values are kept in the original values. The best thermal 
characteristics for a motor are achieved with the highest drive switching frequency. 

The system voltage also affects the servomotor maximum speed and available 
short-term torque at high speeds. You will notice this by changing the system 
voltage, for example, from 380V to 400V or 415V, and by monitoring the short-term 
torque of the same motor.  

Notice: Stall torque allowing 30 seconds at zero sp eed in maximum.   

 

If you select ExistingServoMotor  or ExistingInductionMotor in the Motor type  
field, the Existing motor  window opens. You can see the input fields for existing 
motor specifications for ExistingServoMotor  in Table 10. You can see the 
definition of loadability curve in Figure 12. Ensure that the motor data are valid for 
the same switching frequency that you are going to select from the drive 
specifications. 

 

Table 10. Existing motors specifications for Existing Servo Motor.   

Specification Options 

Type designation Any text or string 
Voltage [V] 400 
Frequency [Hz] 50 
Power [kW] 0.62 
Poles 2, 4, 6, 8, 10, 12, 14, 16, 18, 20 
Speed [rpm] 1500 
Efficiency [%] 90 
IC class IC410 
Temp. rise class B[<80K], F[<105K] 
Mcs 3,9 
Mn 3,9 
Mp0 14 
Mp1 14 
Mp2 14 
n1 1500  
n2 1500  
n3 6000 
Kt  3.04  
Inertia [Kgm^2] 0,001 
Luv [H] 0.004 
Ruv [ohm] 2 
Back EMF [V] 190 
 

Where Kt is torque constant [Nm/A], Luv is line-to-line armature inductance [H] and 
Ruv is line-to-line armature resistance [ohm]. 
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Figure 12. The definition of loadability curve 

 

You can see the input fields for existing motor specifications for 
ExistingInductionMotor in Table 11. 

 

Table 11. Existing motors specifications for Existing Induction Motor.   

Specification Options 

Type designation Any text or string 
Voltage [V] 400 
Frequency [Hz] 50 
Power [kW] 1 
Poles 2, 4, 6, 8, 10, 12, 14, 16, 18, 20 
Speed [rpm] 1000 
Efficiency [%] 90 
Power factor 0.8 
Tmax/Tn 3 
Temp. rise class B[<80K], F[<105K] 
Inertia [Kgm^2] 0.001 
IC class IC411, IC416 

 

5.5.3 Importing own motor list 

You can perform dimensioning with motors from your own motor list. Options are 
Import user motors and Import user induction motors. For User motors, refer to the 
DriveSize manual.  

 
(Mp1, n1) (Mcs, 0) 

(0, n3) 

(Mn, Speed) 

(Mp2, n2) 

(Mp0, 0) 
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5.6 Gearing input data 
To enter gearings data, open the Gearing  display (see Figure 13) by clicking the 
Gearing  icon in the System configuration  tree. You can set a maximum of three 
gears. Each has its own view and data input field. 

 

This software does not include an automatic gear ratio optimization. Set the gear 
ratio so that the maximum speed is as close to the maximum speed of motor as 
possible.  

 

 

Figure 13. Gearings input data display 

 

The visible gearing settings are determined according to the selected gearing type. 
Select the desired gearing type from the Type drop down list (see Figure 14). The 
order of gearings from the motor to the load is: Motor - 1st - 2nd - 3rd - Load. 

. 

The available gearing type options are: 

·  None 
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·  Gear/gear 

·  Gearbox 

·  Chain and sprocket 

·  Belt and pulley 

 

 
Figure 14. Gearing data input field 

 

5.6.1 Belt and pulley 

In belt and pulley gearings the power is transmitted from one pulley to another via a 
belt (see Figure 15). The ratio of gearing depends on the diameters of the pulleys. 

 

 
Figure 15. Belt and pulley  

 

You can enter the driver pulley inertia, driven pulley inertia and coupling inertia 
directly, or you can use the inertia and mass calculator (see chapter 5.1.3. Inertia 
and mass calculator). 

You can see the input fields for the belt and pulley gearing in Table 12. 

Table 12. Belt and pulley gearing settings 
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Setting Explanation 

Driver pulley, Diameter [m] Enter the exact actual diameter of the 
driver pulley for the correct calculation of 
reflected inertia. 

Driver pulley, Inertia [kgm2] Enter the value of the driver pulley inertia 
or use the inertia and mass calculator. 

Driven pulley, Diameter [m] Enter the driven pulley diameter. The 
speed of driven pulley rotation depends 
on the belt velocity and the diameter of 
the pulley. Therefore, the exact value of 
the driven pulley diameter is required for 
the correct calculation of the reflected 
inertia value. 

Driven pulley, Inertia [kgm2] Enter the value of the driven pulley inertia 
or use the inertia and mass calculator. 

Belt mass [kg] Enter the belt mass. It has an effect on 
the value of total inertia. 

Coupling inertia [kgm2] Enter the inertia of coupling at the motor 
side of the gearing or use the inertia and 
mass calculator. This value should also 
include all additional coupling inertia that 
is not included in the driver pulley inertia 
value, for example, the additional inertia 
caused by the shaft. 

Efficiency [%] With the efficiency setting you can take 
into account the losses of torque. In 
MCSize the losses are assumed to 
happen between the belt and driven 
pulley.  

 

5.6.2 Chain and sprocket  

In chain and sprocket gearings the ratio of gearing is inversely proportional to the 
speeds of the sprockets, that is, to the number of teeth on the sprockets (see Figure 
16). 
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Figure 16. Chain and sprocket 

 

You can enter the driver sprocket, driven sprocket inertia and coupling inertia 
directly, or you can use the inertia and mass calculator (see chapter 5.1.3. Inertia 
and mass calculator). 

You can see the input fields for chain and sprocket gearing in Table 13. 

Table 13. Chain and sprocket gearing 

Setting Explanation 

Driver sprocket, Number of teeth Enter the number of teeth on the Driver 
sprocket. This value along with the 
Driven sprocket, Number of teeth  
value generates the gear ratio. The ratio 
is smaller when reducing the value. 
MCSize accepts also the value 1. 

Driver sprocket, Inertia [kgm2] Enter the driver sprocket inertia value or 
use the inertia and mass calculator to 
define the inertia value. 

Driven sprocket, Number of teeth The number of teeth on the Driven 
Sprocket. This value along with the 
Driver sprocket, Number of teeth  value 
generates the gear ratio.  

Driven sprocket, Inertia [kgm2] Enter the driven sprocket inertia value or 
use the inertia and mass calculator to 
define the inertia value. If you want to 
use the inertia and mass calculator, you 
must know the gear diameter. 

Coupling inertia [kgm2] Enter here the inertia of coupling at the 
motor side of that gearing. This value 
should also include all additional coupling 
inertia that is not included in the driver 
pulley inertia value, for example, the 
additional inertia caused by the shaft. 
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Efficiency [%] With the efficiency setting you can take 
into account the losses of torque. In 
MCSize the losses are assumed to 
happen between the chain and driven 
sprocket.  

Chain mass [Kg] Enter chain mass information. It affects 
the value of total inertia. 

Driver sprocket diameter [m] Enter the true diameter of the driver 
sprocket in order to define the chain's 
effect on the reflected inertia value. 

 

5.6.3 Gear/gear 

The gear ratio of gear construction is inversely proportional to the gear speeds, that 
is, to the number of teeth on the gears (see Figure 17). The correct gear ratio is 
required in the calculation of reflected inertia. You can enter the driver and driven 
inertia directly or use the inertia and mass calculator. 

 
Figure 17. Gear/gear 

 

You can see the input fields for gear/gear gearing in Table 14. 

 

Table 14. Gear/gear gearing settings  

Setting Explanation 

Driver gear, Number of teeth Enter here the number of teeth on the 
Driver gear. This value along with the 
Driven gear, Number of teeth  value 
generates the transformation ratio. 
MCSize accepts also the value 1. 

Driver gear, Inertia [kgm2] Enter the driver gear inertia value or use 
the inertia and mass calculator to define 
the inertia value. If you want to use the 
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inertia and mass calculator to define the 
inertia value, you must also know the 
driver gear diameter. 

Driven gear, Number of teeth The number of teeth on the Driven gear. 
This value along with the Driver gear, 
Number of teeth  value generates the 
transformation ratio. 

Driven gear, Inertia [kgm2] Enter the driven gear inertia value or use 
the inertia and mass calculator to define 
the inertia value. If you want to use the 
inertia and mass calculator to define the 
inertia value, you must also know the 
gear diameter. 

Coupling inertia [kgm2] Enter the inertia of coupling on the power 
input side of the gearing or use the inertia 
and mass calculator to define the inertia 
value. This value should also include all 
additional coupling inertia that is not 
included in the driver pulley inertia value, 
for example, the additional inertia caused 
by the shaft. 

Efficiency [%] Enter the efficiency. With the efficiency 
setting you can take into account the loss 
of torque. In MCSize the losses are 
assumed to happen in the teeth of gears.  

 

5.6.4 Gearbox  

The gearbox is an enclosed gearing, that is, a planetary gear for the gearing of 
higher rotation speed (see Figure 18). The purpose of a gearbox is to achieve 
output with high torque and low speed. The gearbox is often integrated into the 
motor. 

 
Figure 18. Gearbox 
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You can see the input fields for gearbox gearing in Table 15. 

Table 15. Gearbox gearing input fields 

Setting Explanation 

Inertia [kgm2] Enter the inertia of the gearbox or use 
the inertia and mass calculator to define 
the inertia value. Typically, gearbox 
manufacturers specify only one value of 
inertia. This inertia is valid at the power 
input of gearbox 

Gear Ratio Enter the gear ratio. This value defines 
how the speed of the input shaft is 
transmitted to the output shaft of the 
gearbox. For example, 3 means that 
three rotations of the input shaft are 
required for one complete turn of the 
output shaft. 

Coupling inertia [kgm2] Enter the coupling inertia at the power 
input side of gearing or use the inertia 
and mass calculator to define the inertia 
value. 

Efficiency [%] With the efficiency setting you can take 
into account the losses of torque. In 
MCSize the losses are assume to 
happen in the teeth of gears. 

 

 

 

5.7 Motion profile and mechanics 

5.7.1 Entering motion profile data 

To open the Motion  display, click the Motion profile and mechanics  icon (see 
Figure 19). Enter motion profile information to the data input fields. When you enter 
a new input value, the program calculates a new motion profile. The results are 
displayed in the Motion results  display. The layout of the Motion results  field 
changes according to the selected mechanics type, whether linear or rotational. 
You can also select an optional unit for distance. Click Change type  to open a 
drop-down list with options for the type of mechanics. 

 



39 

Sizing 

 
Figure 19. Motion input data 

 

You can see the input fields of Motion  display in Table 16. 

 

Table 16. Motion input fields 

Setting Explanation 

Duty type Select the duty type. The Simple cyclic  
duty type consists of just one profile that 
includes the acceleration, continuous 
speed and deceleration segments. If the 
Multiform cyclic  duty type is selected, 
you can create more complicated cycles, 
for example, enter several acceleration 
and deceleration segments. Enter the 
data in the separate Motion profiles  
display (see Figure 20). With several 
accelerations, it is possible to accelerate 
or decelerate from one nonzero speed to 
another nonzero speed. A motion profile 
can contain a maximum of 50 segments, 
including acceleration, deceleration, 
constant speed, dwell and hold 
segments. Only simple cyclic is available 
for Winder and Unwinder mechanics.  

Profile type Select the profile type. The available 
profile type options are the following: 

Trapezoidal 1/3, 1/3, 1/3 

Trapezoidal 1/4, 1/2, 1/4 

Triangular 1/2, 1/2 

User defined 

Fractional numbers here refer to the 
relative times of acceleration, continuous 
velocity and deceleration. Acceleration 
time and deceleration time become 
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editable when the profile type is User 
defined.  

Accel/ Decel type Select the acceleration/deceleration 
type. You can increase the smoothness 
of motion with this option. S-curves are 
used when it is necessary to limit the 
acceleration change rate (jerk). These 
curves are also used in dynamic braking. 
The available s-curve options are the 
following: 

Linear 

1/4 s curve 

5/8 s curve 

Full s curve  

You can achieve the smoothest motion 
with the Full s-curve  setting, but it 
requires higher peak acceleration and 
deceleration to produce an equivalent 
profile. This means that when s-curves 
are used, more torque is required to 
accelerate or decelerate the system 
inertias. 

Movement distance [m],  

Top speed [m/s] 

Rotational angle [deg] 

Number of revolutions 

Enter the total distance traveled during 
the cycle. Acceleration/deceleration is 
calculated on the basis of given distance 
and movement time. When linear load is 
selected, the options are Movement 
distance [m]  and Top speed [m/s] . 
When a rotational movement type is 
selected, a drop down list with three 
options, Rotational angle [deg] , 
Number of revolutions  and Top speed 
[rev] , appears. 

Movement time [s] Enter the total movement time for one 
cycle. Includes the acceleration, constant 
speed and deceleration segments but 
does not include the dwell time. 

Dwell time [s] Enter the waiting time between 
sequential cycles. 

 

5.7.2 Entering more complex profile 

To enter the more complicated duty type, select Multiform cyclic  from the motion 
input data view (see Figure 19). Select a suitable segment type from the drop-down 
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list for each segment. Enter the data for different segment types in the input fields 
and the software calculates the rest (see Table 17). MCSize will display an error 
message in the motion profile view when entered inputs are incomplete for 
example, if the final speed of the previous segment does not fit with the new 
segment. A new row appears automatically after you have entered acceptable 
inputs for the segment. Click the right mouse button to delete or to insert a new 
segment between two segments. Select the segment you want to delete or a 
segment after which you want to insert a new segment. The profile is shown also in 
graphical form. Graph type options Speed vs. time  and Displacement vs. time  are 
available for graphics. 

There is also a possibility to graphically reshape the profile by mouse. Select Edit  
from Graph options, use mouse and point out the segment you want to divide into 
two parts. Click right mouse button and select Add point , click left mouse button 
and a new point appear. Similarly use Delete line  command to remove segments. 
Select Drag from Graph Options, use mouse and left mouse button to move the red 
dots. 

 

 

Figure 20. Motion profiles display 
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Use Graph Settings to change the scale of graph. Enter the new values of axis and 
click Update  push button.  

The zoom function is available when the total cycle time exceeds ten seconds or 
the number of segments is ten or more. Select Enable Zoom , use mouse and left 
mouse button to highlight a period you want to zoom in.  

Click the  push button to zoom out. 

 

You can see the input fields of Multiform cyclic  display in Table 18. 

 

Table 17. Segment types 

Point type Explanation 

Speed & Accl/Decl For the acceleration or deceleration 
segment. Enter the final velocity in the 
end of this segment and the desired 
value of acceleration. Negative 
acceleration means deceleration when 
the speed is positive and vice versa.  

Speed & Time For the acceleration or deceleration 
segment. Enter the duration or 
accelerating/decelerating segment and 
the final speed in the end of this 
segment. The initial speed and the end 
speed must have the same sign (both 
negative or both positive). Reversal is 
possible via zero speed point only. 

Speed & Distance For the acceleration or deceleration 
segment. Enter the final velocity at the 
end of this segment and the desired 
distance to be travelled during this 
segment. The distance and the speed 
must have the same direction (both 
negative or both positive) 

Accl/Decl & Distance Segment type for acceleration or 
deceleration segment. Enter the desired 
acceleration and the distance for the 
segment. Negative value means 
deceleration when the speed is positive 
and vice versa. 

Accl/Decl & Time Segment type for the acceleration or 
deceleration segment. Enter the desired 
acceleration and the duration of 
acceleration for the segment. Negative 
acceleration means deceleration when 
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the speed is positive and vice versa. 

Distance & Time For the acceleration or deceleration 
segment. Enter the duration of this 
segment and the desired distance to 
travel during the segment. Negative 
distance means that the direction of 
movement is negative. 

Dwell segment This is zero speed and no-load waiting 
segment between motion segments. The 
final speed of the previous segment must 
be zero. Enter the duration of dwell 
segment 

Const. speed – distance only For the constant speed segment. Enter 
the distance traveled during this 
segment. Speed is the final speed of 
previous segment. The previous 
segment determines the direction of 
movement. 

Const. speed – time only For the continuous speed segment. 
Enter the duration of constant speed 
segment. Speed is the final speed of the 
previous segment. The previous 
segment determines the direction of 
movement. 

Hold segment This is zero speed hold segment 
between motion segments. Hold torque 
is determined by mechanics. Enter the 
duration of hold segment. The end speed 
of the previous segment must be zero. 

  

Table 18. Motion profile inputs for Multiform cyclic load type 

Setting Explanation 

Segment Sequence number. You can enter 2…50 
segments. 

Segment Type Speed & Accl/Decl, Speed & Time, 
Speed & Distance, Accl/Decl & Distance, 
Accl/Decl & Time, Distance & Time, 
Dwell segment, Const. speed – distance 
only, Const. speed – time only, Hold 
segment. 

Accel/DeclType Select the acceleration/deceleration 
type. You can increase the smoothness 
of motion with this option. S-curves are 
used when it is necessary to limit the 



44 

Sizing 

acceleration change rate (jerk). The 
available s-curve options are the 
following: 

Linear 

1/4 s curve 

5/8 s curve 

Full s curve  

You can achieve the smoothest motion 
with the Full s-curve  setting, but it 
requires higher peak acceleration and 
deceleration to produce an equivalent 
profile. This means that when s-curves 
are used, more torque is required to 
accelerate or decelerate the system 
inertias. 

Time [s] The duration of the segment.  

Speed [m/s], [rad/s] The end speed for acceleration or 
deceleration segment. 

Distance [m], [rad] Angular distance traveled during the 
duration of the segment. 

Accel/Decl [m/s2], [rad/s2] The mean value of acceleration for the 
segment. A positive sign means 
acceleration to the positive direction and 
vice versa. A negative sign means 
deceleration when the direction of the 
movement is positive and vice versa.  

Total Dist. [m], [rad] Total distance or angular distance from 
the start position to the end position. 

 

 

5.7.3 Entering mechanics data 

You can select the type of the mechanical application from the Type drop-down list 
in the Mechanics  display (see Figure 21). 

The available mechanics types are the following: 

·  Conveyor, which is also the default 

·  Cylinder 

·  Feed roll 

·  Lead screw 

·  Rack & pinion 
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·  Rotating table 

·  User defined 

·  Winder 

·  Unwinder 

 

Each item has its own view and input fields. User defined  and Cylinder  are more 
universal mechanics types for linear and rotational movements respectively. 

 

 
Figure 21. Mechanics input data 

 

You can use the inertia and mass calculator to calculate the inertia of mechanical 
parts on the basis of their dimensions, weight and material. To open the inertia and 
mass calculator, click the calculator button next to an inertia input field. 

 

5.7.3.1 Conveyor 

Industrial conveyors are material handling machinery that are used for moving bulk 
materials from one place to another at a controlled rate (see Figure 22). A belt 
conveyor consists of an endless loop belt and a roller system in which idler rollers 
are often used to support the belt. The belt position can be horizontal, inclined or 
declined. The direction of movement is mostly forward but reverse is also possible. 
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Figure 22. Conveyor mechanics 

 

You can see the input fields for conveyor mechanics in Table 19. 

 

Table 19. Conveyor mechanics settings 

Setting Explanation 

Load Mass [kg] Enter the total mass of the load to be 
conveyed. 

Belt Mass [kg] Enter the belt mass. It affects the value 
of total inertia and the frictional forces. 

Driver roller, Diameter [m] Enter the exact driver roller diameter for 
the correct calculation of driven roller 
inertia, load inertia, belt inertia and idle 
roller inertia. 

Driver roller, Inertia [kgm2] Enter the value of driver roller inertia or 
use the inertia and mass calculator to 
define the inertia value. 

Driven roller, Diameter [m] Enter the driven roller diameter for the 
calculation of the effect of the inertia of 
these rollers on the system inertia. 

Driven roller, Inertia [kgm2] Enter the driven roller inertia or use the 
inertia and mass calculator to define the 
inertia value. The rotation speed of the 
driven roller depends on the belt velocity 
and the diameter of the driven roller. For 
correct inertia value calculations, enter 
the exact diameter of the driven roller. 

Idler roller, Diameter [m] Enter the idler roller diameter for the 
calculation of the effect of the inertia of 
these rollers to the system inertia. 
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Idler roller, Inertia [kgm2] Enter the total inertia for all the idler 
rollers (typically there are several idler 
rollers to support the belt) or use the 
inertia and mass calculator to define the 
inertia value. Notice that you must enter 
the exact diameter of the idler rollers for 
the correct calculation of system inertia. 
Use zero value when there are no 
rotating idler rollers in the conveyor. 

Coupling Inertia [kgm2] Enter the inertia of the coupling between 
the gearings and the conveyor or use the 
inertia and mass calculator to define the 
inertia value. This value should also 
include all additional coupling inertia that 
is not included in the driver pulley inertia 
value, for example, the additional inertia 
caused by the shaft. 

Efficiency [%] Enter the efficiency percentage of the 
conveyor mechanics. You can take into 
account power losses with efficiency. 
The efficiency value defines how much 
more torque is needed due to the losses.  

Incline Angle [deg] Enter the incline angle between the belt 
and the horizontal plane. Only a positive 
value of the incline angle is possible. 
Positive distance means upward motion 
and negative distance means downward 
motion. 

Coefficient of friction Enter the coefficient of friction. It takes 
into account all the frictional losses of the 
conveyor system due to the load and 
belt. It includes the friction between the 
guides and the belt, the belt and the 
rollers as well as the bearing friction of 
the rollers. It is assumed that frictional 
losses are independent when the angle 
is inclined. 

Opposing force [N] Enter the sum of forces acting against 
the belt movement, for example, thrust 
load trying to push the load off from the 
belt. 
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5.7.3.2 Cylinder 

In MCSize the cylinder drive is the universal load type for rotational 
movement (see Figure 23). For example, a load can consist of several 
cylinders with different diameters that are attached to a common shaft. 

 
Figure 23. Cylinder drive mechanics 

 

You can see the input fields for cylinder drive mechanics in Table 20. 

 

Table 20. Cylinder mechanics settings 

Setting Explanation 

Load inertia [kgm2] Enter the total inertia of the cylinder or 
use the inertia and mass calculator to 
define the inertia value. 

Coupling inertia [kgm2] Enter the inertia of the coupling between 
the gearing and the cylinder drive 
mechanics or use the inertia and mass 
calculator to define the inertia value. This 
value should also include all additional 
inertia that is not included in the load 
inertia value, for example, the additional 
inertia caused by the shaft. 

Efficiency [%] Enter the efficiency percentage (the 
percentage of the input torque provided 
to output). The losses of the cylinder 
drive mechanics are taken into account in 
the efficiency. 

Conversion diameter [m] Enter the diameter for thrust force. The 
thrust load diameter is the doubled 
distance between the center of the 
cylinder shaft and the impact point of the 
opposing force. 
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Opposing force [N] Enter the total sum of opposing forces in 
this input field. The opposing forces 
include, for example, the thrust load 
acting against the movement at a certain 
radius on the load. 

 

5.7.3.3 Feedroll 

You can see the example of feedroll mechanism in the Figure 24. 

 
Figure 24. Feedroll mechanics 

 

You can see the input fields for feed roll mechanics in Table 21. 

 

Table 21. Feed roll mechanics settings 

Setting Explanation 

Load mass [kg] Enter the total load of the material to be 
moved. 

Number of rolls, Driver roller Enter the number of driver rolls in the 
feedroll. 

Number of rolls, Pinch Enter the number of rolls in the pinch. 

Inertia, Driver roller Enter the driver roller inertia or use the 
inertia and mass calculator to define the 
inertia value. 

Inertia, Pinch Enter the pinch inertia or use the inertia 
and mass calculator to define the inertia 
value. The rotation speed of the pinch 
feed roll depends on the strip velocity 
and the diameter of the roller. 

Diameter, Driver roller Enter the exact diameter of the driver 
roller for correct load inertia and 
tensional torque calculations. 
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Diameter, Pinch Enter the exact diameter of the pinch for 
correct system inertia calculations. 

Coupling inertia [kgm2] Enter the inertia of the coupling between 
the gearing and the feed roll mechanics 
or use the inertia and mass calculator to 
define the inertia value. This value 
should also include all additional coupling 
inertia that is not included in the driver 
roller inertia value, for example, the 
additional inertia caused by the shaft.  

Efficiency [%] Enter losses that should be taken into 
account in the torque efficiency. This 
data defines how much more torque is 
needed because of the losses. 

Strip tension [N] Enter the tensional force or pull through 
force that is needed to achieve the 
desired material tension on the input side 
of the roller system. 

Frictional force [N] Enter the tensional force that is needed 
to pinch the strip material in the roller 
system. 

 

 

5.7.3.4 Lead screw 

A lead screw consists of a screw with a nut moving along it (see Figure 25). The 
rotational motion of the screw turns to the linear motion of the nut. The high torque 
and low speed of the linear motion can be achieved depending on the value of the 
screw pitch. The screw position can be horizontal, vertical, inclined or declined. Use 
counterbalance to eliminate the gravitation component caused by the incline angle, 
if necessary. 

 
 

 
Figure 25. Lead screw mechanics 
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You can see the input fields for lead screw mechanics in Table 22. 

 

Table 22. Lead screw mechanics settings 

Setting Explanation 

Load mass [kg] Enter the total load mass to be 
transported. 

Table mass [kg] Enter the mass of the table. It has an 
effect on the value of total inertia and on 
the frictional forces. All the linearly 
moving parts (for example, the nut) are 
taken into account here. 

Counter balance mass [kg] If counterbalance is used, enter its mass. 
Note that the acceleration of free fall, or 
9.82 m/s2, is the natural maximum limit 
for acceleration when counterbalance is 
used. If no counterbalance is used, enter 
zero value to this input field. 

Lead screw Inertia [kgm2] Enter the screw inertia or use the inertia 
and mass calculator to define the inertia. 

Coupling inertia [kgm2] Enter the inertia of the coupling between 
the gearings and the conveyor or use the 
inertia and mass calculator to define the 
inertia value. This value should also 
include all additional coupling inertia that 
is not included in the screw inertia value, 
for example, the additional inertia caused 
by shafts. 

Efficiency [%] Enter the efficiency percentage of lead 
screw mechanics. The losses of lead 
screw mechanics, for example, the loss 
of power due to friction in the bearings, is 
taken into account with efficiency. The 
value indicates how much more torque is 
needed due to the losses. 

Incline angle [deg] Enter the incline angle between the 
screw and the horizontal plane. Only a 
positive value of the incline angle is 
possible. Positive distance means 
upward motion and negative distance 
means downward motion. 

Coefficient of friction Enter the coefficient of friction. It takes 
into account the frictional losses between 
the table and the support or the guide 
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bar. These losses are caused by the total 
weight of the load and the table. This 
opposing component is dependent on the 
cosine of incline angle. 

Opposing force [N] Enter the sum of all opposing forces that 
affect the movement of the table, for 
example, the thrust load or the preload 
force. Preload is the opposing force that 
must be overcome before the load starts 
to move. 

Lead screw pitch [mm] Enter the linear distance the nut 
advances for one complete turn of the 
screw. 

 

5.7.3.5 Rack & pinion 

The rack & pinion mechanics consist of pinion and rack gears that transfer the 
rotational motion of the pinion to the linear movement of the rack (see Figure 26). 
The rack position can be horizontal, vertical, inclined or declined. 

 

 
Figure 26. Rack and pinion mechanics 

 

You can see the input fields for rack and pinion mechanics in Table 23. 

 

Table 23. Rack and pinion mechanics settings 

Setting Explanation 

Load mass [kg] Enter the total load mass to be 
transferred. 

Rack mass [kg] Enter the mass of the rack including the 
mass of all parts that move linearly. 

Pinion diameter [m] Enter the exact pitch circle diameter of 
the pinion for the correct calculation of 
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load inertia, rack inertia, etc. 

Pinion inertia [kgm2] Enter the inertia of the pinion or use the 
inertia and mass calculator to define the 
inertia value.  

Coupling Inertia [kgm2] Enter the inertia of coupling between 
gearings and pinion or use the inertia and 
mass calculator to define the inertia 
value. This value should also include all 
additional coupling inertia that is not 
included in the pinion inertia value, for 
example, the additional inertia caused by 
shafts. 

Efficiency [%] Enter the losses of rack & pinion 
mechanics. For example, the frictional 
loss of bearings is taken into account in 
the efficiency coefficient. The efficient 
defines how much more torque is needed 
due to the losses. 

Incline angle [deg] Enter the incline angle. It is the angle 
between the rack and the horizontal 
plane. Only a positive value of the incline 
angle is possible. Positive distance 
means upward motion and negative 
distance means downward motion. 

Coefficient of friction Enter the coefficient of friction. It takes 
into account the frictional losses between 
the rack and the support. These losses 
are caused by the total weight of the load 
and the rack. This opposing component 
depends also on the cosine of the incline 
angle. 

Opposing force [N] Enter the thrust load, that is, the sum of 
forces that effects against the movement 
of the rack. 

 

 

5.7.3.6 Rotating table 

A horizontally rotating table is controlled through a shaft and a coupling (see Figure 
27). The table moves and positions bulk loads. 
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Figure 27. Rotating table mechanics 

 

You can see the input fields for rotating table mechanics in Table 24. 

 

Table 24. Rotating table mechanics settings 

Setting Explanation 

Load mass [kg] Enter the total load mass to be moved. 

Load - center distance [m] Enter the distance between the center of 
the table and the center of the weight. 
The radius can be defined as the average 
of the inside radius and outside radius. 
The inertia of the load depends on its 
position in relation to the center of the 
table. 

Table inertia [kgm2] Enter the inertia of the table and the shaft 
or use the inertia and mass calculator to 
define the table and shaft inertia value. 

Coupling inertia [kgm2] Enter the inertia of the coupling between 
the gearings and the rotary table or use 
the inertia and mass calculator to define 
the inertia value. This value should also 
include all additional coupling inertia that 
is not included in the table inertia value, 
for example, the additional inertia caused 
by shafts. 

Efficiency [%] Enter the efficiency percentage of input 
power provided to output. The efficiency 
value takes into account the losses of the 
rotating table mechanics. 

Opposing force distance [m] Enter the opposing force distance. It is 
equivalent to the distance from the center 
of the table to the impact point of 
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opposing frictional force. 

Opposing force [N] Enter the opposing force. The opposing 
force can be any additional frictional force 
that acts on a certain area from the 
center of the table. 

 

5.7.3.7 User defined 

User defined is the universal load type for linear movement in this software. The 
inertia of linear load is converted to rotational movement with the conversion 
diameter defined by the user. See the general structure of user defined mechanics 
in Figure 28. 

 

 

Figure 28. User defined mechanics 

 

You can see the input fields for user defined mechanics in Table 25. 

Table 25. User defined mechanics settings 

Setting Explanation 

Load mass [kg] Enter the total load mass to be 
conveyed. 

Conversion diameter [m] Enter the conversion diameter. The 
diameter defines the distance the load 
travels for the full revolution of the input 
shaft. The distance is equal to p 
multiplied by the conversion diameter. 

Coupling inertia [kgm2] Enter the inertia of coupling between the 
gearing and the user defined mechanics 
or use the inertia and mass calculator to 
define the inertia value. You can add any 
load side rotating inertia to this input 
field. 

Efficiency [%] Enter the losses of user defined 
mechanics. For example, frictional losses 
are taken into account in the efficiency. 
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The system's efficiency is defined as the 
percentage of the input torque provided 
to output. 

Coefficient of friction Enter the coefficient of friction. It takes 
into account the frictional losses caused 
by the weight of load. 

Opposing force [N] Enter the sum of any opposing forces 
that affect the movement of linear load, 
for example, thrust load. 

 

 

5.7.3.8 Winder 

A centerwind type of mechanics winds material around a core or a reeling drum 
(see Figure 29). In this type of winder the center of coil is driven by motor. In the 
figure the positive direction of angular speed and tension are shown. The MCSize 
assumes that winding starts from minimum diameter to maximum without stops. 
Due to this the Multiform cyclic Duty type is not valid.  

 

 
 

Figure 29. Winder mechanics. 

 

You can see the input fields for winder mechanics in Table 26. 

 

Table 26. Winder mechanics settings 

Setting Explanation 

Max diameter [m] Diameter of the complete coil. 

Min diameter [m] This is the initial value of diameter when 
rewinding starts. In many cases this is 
the diameter of core or reeling drum. 

Coupling inertia [kgm2] Enter the inertia of coupling between the 
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gearing and the winder mechanics or use 
the inertia and mass calculator to define 
the inertia value. You can add any load 
side rotating inertia to this input field. 

Core inertia [kgm2] Enter the total inertia of core and shaft or 
use the inertia and mass calculator to 
define the inertia value. This is the initial 
value of inertia. 

Efficiency [%] Enter the efficiency percentage of input 
torque provided to output. The efficiency 
value takes into account the losses of the 
winder mechanics like bearings. 

Width [m] Enter the width of material.  

Density [kg/m3] Enter material density information. It 
affects the value of inertia. 

Tension [N] Enter the tensional force that is needed 
to achieve the desired material tension. 

Opposing force [N] Enter the sum of any opposing forces 
that affect the movement of reeled 
material. This force is acting against 
movement at the surface of the coil.   

 

 

5.7.3.9 Unwinder 

A centerwind type of mechanics is unwinding material from reel (see Figure 30). In 
this type of winder the center of coil is driven by motor. When the positive directions 
are according to the figure the normal running power is negative and will be shown 
in second quadrant in torque speed diagram. The MCSize assumes that winding 
starts from maximum diameter to minimum without stops. Due to this the Multiform 
cyclic Duty type is not valid.  

 

 

Figure 30. Unwinder mechanics. 
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You can see the input fields for winder mechanics in Table 27. 

 

Table 27. Unwinder mechanics settings 

Setting Explanation 

Max diameter [m] Diameter of the full coil. This is the initial 
value of diameter when unwinding. 

Min diameter [m] This is the final value of diameter when 
unwinding ends. In many cases this is 
the diameter of core or reeling drum. 

Coupling inertia [kgm2] Enter the inertia of coupling between the 
gearing and the winder mechanics or use 
the inertia and mass calculator to define 
the inertia value. You can add any load 
side rotating inertia to this input field. 

Core inertia [kgm2] Enter the total inertia of core and shaft or 
use the inertia and mass calculator to 
define the inertia value. 

Efficiency [%] Enter the efficiency percentage of input 
torque provided to output. The efficiency 
value takes into account the losses of the 
unwinder mechanics like bearings. 

Width [m] Enter the width of material.  

Density [kg/m3] Enter material density information. It 
affects the value of coil inertia. 

Tension [N] Enter the tensional force that is needed 
to achieve the desired material tension. 

Opposing force [N] Enter the sum of any opposing forces 
that affect the movement of reeled 
material. This force is acting against 
movement at the surface of the coil.   

 

 

 

 

5.7.4 Inertia and mass calculator 

When entering inertia data, for example, in the Motor load , Gearing  or Mechanics  
displays, you can use the Inertia and mass calculator v1.1© program developed by 
ControlEng Corporation for the calculation of inertia (see Figure 31). 
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Click the calculator button ( ) next to the Inertia [kgm 2] value fields to open the 
inertia and mass calculator. 

 

To calculate the inertia and mass with the inertia and mass calculator: 

1. Select the element shape and, in most cases, enter the dimensions of the 
mechanical component. 

2. Enter the material and density. The mass and the inertia are calculated 
automatically and displayed in the Mass and Inertia  fields. 

3. Add the calculated mass and inertia to the Calculation Table  field for the 

calculation of total mass and inertia by clicking the  (positive) or  
(negative) button at the bottom of the Inputs  field. To replace an active row 
from the Calculation table with the information in the Inputs  field, click the 

 button. 

4. Feed another mass and inertia information and add it to the totals, if 
necessary. 

 

To remove a row from the Calculation Table , activate it and click the  button.  

To display and modify information in a row in the Calculation Table  in the Inputs  

field, activate the row and click the  button. 

Note that the unit of inertia must be kg-m 2. 
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Figure 31. Inertia and mass calculator 

 

5.8 Sizing examples 
The software includes example project files that include pre-filled input data. With 
these files you can learn quickly how the software works and how to enter data. 

To open a sizing example file: 

 Select File > Examples and pick the desired file from the list. 

5.9 Network check 
Use Network check  for harmonics calculation. Refer to the DriveSize user manual, 
Chapter 5 – Network check.  
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6 Results 

6.1 Motion and mechanics results 
To open the Motion results display (see Figure 32), click the Motion  icon in the 
System configuration tree.  

Motion results, mechanical results and combined results are calculated immediately 
when new data is entered to the Motion and Mechanics input fields. 

6.1.1 Motion results 

The calculation of motion results is based on the Motion profile input data. 

The results are also shown in graphical form. The motion profile graph in the 
Motion results  display includes two Graph type  display options, Speed vs. time  
and Displacement vs. time . 

 

 
Figure 32. Motion results  

 

You can see the result fields of the Motion results display in Table 28. These values 
produce the profile that is entered to the input fields of the motion display.  

Table 28. Motion results 
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Result Explanation 

Acceleration time [s] Calculated acceleration time. This field is 
editable when the Profile type is  User 
Defined . 

Deceleration time [s] Calculated deceleration time. This field is 
editable when the Profile type is User 
Defined .  

Acceleration [m/s2], [deg/s2] or [1/s2] Calculated equivalent value of 
acceleration. Units are selected 
automatically depending on whether 
linear or rotational movement is used. 

Deceleration [m/s2], [deg/s2] or [1/s2] Calculated equivalent value of 
deceleration. Units are selected 
automatically depending on whether 
linear or rotational movement is used. 

Max velocity [m/s], [deg/s] or [rpm] Calculated maximum velocity  

Velocity at max dyn power [m/s], [rpm] or 
[deg/s] 

When S-curves are applied the 
movement speed where the maximum 
power is required is not at maximum 
speed but lower.   Applying s-curves 
might allow smaller motors than without 
because the high torque at max speed is 
avoided. 

 

6.1.2 Mechanical results 

The values displayed in the Mechanical results  field (see Figure 33) are only 
intermediate results and they are true at the input shaft of mechanics. Gearings are 
not taken into account here. 

 

 
Figure 33. Mechanical results  

 

You can see the items in the Mechanical results field in Table 29. 

 

Table 29. Mechanical results  

Result Explanation 
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Opposing torque [Nm]  Intermediate opposing torque for 
mechanics only. Motor and gearings are 
not taken into account. 

Equivalent inertia [Kgm2] Intermediate inertia at input shaft for 
mechanics only. Motor and gearings are 
not taken into account. 

 

6.1.3 Combined results at driver shaft 

The combined results for motor selections are displayed in the Combined results  
field (see Figure 34). These results are true at the input shaft of mechanical 
application. Gearings are not taken into account. 

 

 
Figure 34. Combined results at the driver shaft  

 

You can see the items in the Combined results field in Table 30. 

 

Table 30. Combined results display items 

Item Explanation 

Max torque [Nm] Calculated maximum torque for given 
profile and mechanics 

Max speed [rpm] Calculated maximum speed for given 
profile and mechanics 

Max power [kW] Calculated maximum torque for given 
profile and mechanics 

RMS torque [Nm] Calculated root mean squared torque for 
given profile and mechanics 

RMS speed [rpm] Calculated root mean squared speed for 
given profile and mechanics. This is the 
speed that corresponds with the 
calculated RMS torque. 
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Speed at max dyn. power [rpm]  Rotational speed where maximum torque 
load exists. This appears when s-curves 
are used.  Applying s-curves might allow 
smaller motors than without because the 
high torque at max speed is avoided. 

 

 

6.2 Gearing results  

To view gearing results, click on the Gearing  icon in the System configuration tree. 
You can see the results of gearings in the Gearing  display, on the right side of the 
gearing settings (see Figure 35). 

 

 
Figure 35. Gearing results 

 

RMS torque and speed are root mean squared results at the input side of gearing. 
The order of gearings is read from the motor output to the mechanics input, that is, 
the 1st gearing is connected to the motor shaft, the 2nd shaft is coupled to the output 
shaft of the 1st gearing, and so on. 

At the bottom of the Gearing  display you can see the total values of all gearings in 
the Gears totally  field (see Figure 36). 

 

 
Figure 36. Total values of all gearings 

 

You can see the results in the Gears totally field in Table 31. 

Table 31. Gears totally result items 

Result Explanation 
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Total gear ratio Combined gear ratio for all gears 

Inertia due to gears [kgm2] Combined inertia of all gears at motor 
shaft 

Overall efficiency [%] Combined efficiency for all gears 

 

6.3 Results menu 
 

To show dimensioning results first select the drive component or the supply unit from 

the tree and then click the  icon or select Result > Dimensioning result .  

6.3.1 Graphs 

To show Graphs, click the  icon or select Result > Graphs . This opens the 
Graph  window that displays graphs for the following graph options: 

·  Load/Motor graph  

·  Inverter 

·  Performance and profile graph 

 

For inverters the following options are available: 

·  Current 

·  DC power 

 

To show supply unit DC power graph, select supply from system configuration tree 
and click the graph icon. 

 

 

6.3.2 Multi-graph view 

To show several graphs at a time, select the components from the system 
configuration tree. To highlight several components use the Ctrl  key, mouse and 
left mouse button. Press and hold down the Ctrl  key when selecting components. 
Select first the object that you want to see uppermost. Two of the graphs are shown 
at once and you can change the lower one by scrolling the graphs. You can show 
the multi-graph view for all graph options (see Figure 37).  
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Figure 37. Performance and profile multi-graph view 

6.3.3 Reports 

To show Reports, select Result > Reports  or click the Report  button in the result 
or graph display. To show more project data sheets at once, see chapter 7.  

6.4 Motor results 
The motor Selection data  is shown in the Motor data  field of the Motor Results  
display (see Figure 38). Calculated margins are between the following values: 

·  Required RMS torque to the nominal torque of motor 

·  Required peak torque to the maximum short term torque of motor 

In the motor data display you can see also Inertia ratio, Max air gap torque, RMS 
torque, Motor copper losses, Specifications and Catalogue data for the selected 
motor. 
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Figure 38. Motor selection data 

 

6.4.1 Motor Graph 

You can see the motor results also in graphical form (see Figure 39 and Figure 40). 
Calculated RMS torque at RMS speed, dynamic torques and limits are illustrated in 
a motor graph. The green torque (speed curve) defines the thermal long-term limits 
of the motor. The red curve defines limits for short term intermittent loads and 
maximum allowed speeds for these loads. These required results are calculated on 
the basis of the motor air gap torque. The effect of motor inertia is also taken into 
consideration. 

The selection criteria for a motor are:  

·  Calculated RMS torque must be inside the range of the Cont loadability  limit.  

·  Dynamic peak torque curve must be inside the range of the Max. loadability 
limit.   
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Figure 39. Motor Graph display for ServoMotor 

 

Please notice in this case the dynamic torque curves. They are shown as black arcs 
and in this close to optimal case they are very close to max torque of motor.  

 

The Motor Graph may have up to four quadrants if the application is braking and 
running in reverse direction at the same time. The required torque curves are not 
shown in full length to keep the graph uncluttered. If s-curves are applied the parts 
of torque curve representing maximum mechanical power are displayed. 

 

Notice that drive’s switching frequency has an effect to torque curves.   

 



69 

Results 

  

Figure 40. Motor Graph display for Induction Motor 

 

 

6.5 Drive results  
In the Drive Results  display you can see the results and specification data for 
Selection data , Specifications , Catalogue data  and Drive losses at RMS speed .  

The selection criteria for a drive are:  

·  Peak current trajectory must be lower than the max current limit. 

·  Calculated RMS current must be lower than the nominal current. 

·  Inverter maximum output power must not be exceeded 

·  Additionally, the dynamic thermal limit is checked 
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Figure 41. Drive results display 

 

 

6.5.1 Drive Graph  

You can see the drive results also in graphical form (see Figure 42). Current/speed 
curves define the limits for continuous (green) and intermittent currents (red). The 
latter current limit depends on drive heatsink temperature, output frequency and 
switching frequency. Calculated RMS current, actual current trajectory and limits 
are shown in the drive graph.   

Also this graph can have two quadrants. 

 



71 

Results 

 

Figure 42. Drive Graph display 

 

Please notice that in this example due to s-curves the acceleration starts smoothly, 
runs most of the time at 2.4A and will easy up at 1520 rpm. The deceleration will 
happen with lower current but with the same idea.   

6.6 Supply unit results  
In the Supply unit data  display you can see the results and specification data for 
Selection data (Figure 43), Specifications , Catalogue data  and Supply unit 
losses . 

The selection criteria for a supply unit are:  

·  Calculated RMS current must be lower than the nominal current. 

·  Peak current must be lower than temperature dependant max current limit. 

·  Additionally, the dynamic thermal current and temperature limits are checked 
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Figure 43. Selection data of supply unit 

 

6.6.1 Supply unit Graph 

You can see the supply unit results in graphical form (Figure 44). There the DC-
power of supply unit is shown in function of time. The graph illustrates the total DC-
power of all inverters connected to that supply unit. 
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Figure 44. Supply unit graph display 

 

6.7 User selection  
User selection functionality is a part of the sizing process and the screen with plenty 
of computed choices is also a part of the results. 

In the User selection  display you can select a smaller or larger unit instead of your 
current selection (made by the software or by your previous other choice selection). 
The selected unit has number 0 and its row is highlighted. Smaller units have a 
negative mark. Larger units have a positive mark. In this table there are some 
catalogue values and calculated margins to help with the new selection process. In 
some cases in which the overloads are decisive there are no smaller units in the 
list. 
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Figure 45. User selection display 
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7 Printing 

This software uses Microsoft Excel for printing. You can use the print and preview 
options if you have Microsoft Excel 97/2000 or later version installed on your 
computer. 

 

You can use the printing function for two purposes: 

·  to export project information to Excel or PDF formats 

·  to print project information on paper. 

 

To print results: 

1. Open the Print  display by:  

·  Clicking the toolbar icon ,  

·  Selecting File > Print  from the menu, or 

·  Pressing the Ctrl+P  short cut key. 

2. Select the items to be moved to Excel. You can print a project data sheet, a 
project technical data sheet or all data sheets for a project (see Figure 46). 

 

�
Figure 46. Print display 

 

3. Click Print  to print the desired information. If you select Setup , you can 
select the printer and print options (Paper size , Source  and Orientation ). 
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8 Help 

 

The software's context sensitive Help file contains the same information as this 
document. 

To open the Help file, select Help > Contents . For information on how to use the 
help, select Help > How to use help . 

Select Help > About  to view MCSize version information.
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