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1. About this manual

1.1. Copyrights
The information in this document is subject to change without notice and should not
be construed as a commitment by ABB Oy. ABB Oy assumes no responsibility for
any errors that may appear in this document.
In no event shall ABB Oy be liable for direct, indirect, special, incidental or
consequential damages of any nature or kind arising from the use of this document,
nor shall ABB Oy be liable for incidental or consequential damages arising from use
of any software or hardware described in this document.
This document and parts thereof must not be reproduced or copied without written
permission from ABB Oy, and the contents thereof must not be imparted to a third
party nor used for any unauthorized purpose.
The software or hardware described in this document is furnished under a license
and may be used, copied, or disclosed only in accordance with the terms of such
license.
Copyright © 2008 ABB Oy
All rights reserved.

1.2. Trademarks
ABB is a registered trademark of ABB Group. All other brand or product names
mentioned in this document may be trademarks or registered trademarks of their
respective holders.

1.3. General
This manual provides thorough information on SPA-ZC 302, which is an interface
module for SPA bus protection relays providing connectivity to the Profibus DP
fieldbus.

1.4. Use of symbols

This publication includes warning, caution, and information icons that point out
safety related conditions or other important information. It also includes tip icons to
point out useful information to the reader. The corresponding icons should be
interpreted as follows:

The warning icon indicates the presence of a hazard which could
A result in personal injury.

to the concept discussed in the text. It might indicate the presence of
a hazard which could result in corruption of software or damage to
equipment or property.

@ The caution icon indicates important information or warning related
LJ
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The information icon alerts the reader to relevant facts and
ﬂ conditions.

Although warning hazards are related to personal injury, and caution hazards are
associated with equipment or property damage, it should be understood that
operation of damaged equipment could, under certain operational conditions, result
in degraded process performance leading to personal injury or death. Therefore,
comply fully with all warning and caution notices.

1.5. Terminology

The following is a list of terms associated with SPA-ZC302 that you should be
familiar with. The list contains terms that are unique to ABB or have a usage or
definition that is different from standard industry usage.

Term

Description

PCT

Profibus DP/SPA Gateway Configuration Tool

SPA

Data communication protocol developed by ABB

SPACOM

ABB product family

1.6. Abbreviations

ABS

AnyBus

ASIC

Application specific integrated circuit

Ch/Cat/Dno

SPA message format:
Channel, category, data number

FCh/LCh/Cat/FDno/LDno

SPA message format:
First channel, last channel, first data number, last data
number

COM

Component object model

CRC

Cyclical redundancy code

DIP

Dual inline pin

DP

Data processing

GND

Ground

GSD

Gerate Stamm Datei, basic Profibus device

LED

Light-emitting diode

LSB

Least significant byte

110

Input/output

MSB

Most significant byte
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N/C Not connected
NACK Negative acknowledgement
RTD Resistance temperature detector
SRAM Static random access memory
TTL Transistor-transistor logic
USB Universal serial bus
1.7. Related documents
Name of the manual MRS number
Standard Configuration Templates 1MRS755177
SPA-ZC 302 configuration CD 1IMRS752534-MCD
1.8. Document revisions
Version |Revision number|Date History
A 1.03.03 14.11.2003 |Document created
B 2.0 16.05.2005 |-Multislave support added
-Packed SPA binary read support
C 2.0 16.05.2008 |-Ordering information updated
1.9. Safety information

/N

Dangerous voltages can occur on the connectors, even though the
auxiliary voltage has been disconnected.

National and local electrical safety regulations must always be
followed.

The device contains components which are sensitive to electrostatic
discharge. Unnecessary touching of electronic components must
therefore be avoided.

The frame of the device has to be carefully earthed.

Only a competent electrician is allowed to carry out the electrical
installation.

Non-observance can result in death, personal injury or substantial
property damage.

Breaking the sealing tape on the upper handle of the device will result
in loss of warranty and proper operation will no longer be guaranteed.

Do not touch the inside of the case. The adapter case internals may
contain high voltage potential and touching these may cause personal
injury.
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2.1.

Introduction

The SPA-ZC 302 is an interface module for SPA bus protection relays, that provides
connectivity to the Profibus DP fieldbus. The Profibus DP specification and the
structure of its messages are defined in the European standard EN50170. The
SPA-ZC 302 is referred to as gateway hereinafter in this document.

The mechanical and electrical connection of the gateway to relays with SPA bus
interface is described in Chapter 3. Installation. Gateway programming is described
in Chapter 4. Commissioning.

As a prerequisite, you should understand the communication properties of the
protection relays that is to be connected to the gateway. This information is available
in the manual for the protection relay in question. It is also necessary to have basic
understanding of the Profibus DP master system that is going to be connected to the
gateway.

Features

« Profibus DP Version 1 connectivity for devices with SPA bus interface
* Internal power supply

Support of SPA bus interface with RS-485, RS-232 or TTL levels

« Easy-to-use configuration tool

Library of pre-defined standard configurations

Support of user defined SPA messages in acyclic Profibus messages

« Support of RS-485 Profibus interface

Support of circuit breaker control operations in selected configurations
Support for up to 16 SPA slaves

Reading multiple binary data by using SPA (packed data read features in
templates)

All relay data can be accessed through the SPA-ZC 302 gateway. If the standard
configuration templates do not include needed data, contact your ABB
representative.

11
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2.2. Module parts

1 Profibus D-connector -
2 SPA bus D-connector [

3 Profibus communication LEDs

For details, see Section 8.3.1. 2

4 SPA communication LEDs *:'1 3

For details, see Section 8.3.1. s sus 8

5 DIP switches AS _4 m;

6 Auxiliary power connector Qe e, o P 1"
SPAITERFACE )

ABB spa-zc3o2

EXTERNAL POWER
0., 240 VAC
u 1
4oce| o 10,220 VDG

L& 1@ ce
* 6
O . |

A050293

Fig. 2.2.-1 Parts of SPA-ZC 302

2.3. Ordering information
SPA-ZC 302-BA

* SPA-ZC 302 module

 Connection cable for configuring SPA-ZC 302 module and connecting SPA
bus relays, for example REF 541/3/5, RET 541/3/5, REM 543/5 and SPACOM
(Order number; 1IMRS120541)

 Connection cable for SPA bus relays, for example REX 521, RE_610 relays
and SACO annunciator units (Order number: 1IMRS120539)

» Gender changer
* This manual
» SPA-ZC 302 configuration CD

With REF 541/3/5, RET 541/3/5 and REM 543/5, the following
ﬂ cable information must be noticed:

» SPA-ZC 302 to port X3.2 (RS-232, protocol 2). Use cable
1MRS120513-003. This has to be ordered separately.

» SPA-ZC 302 to port X3.3 (RS-485, protocol 3). Use cable
1MRS120541 included in the delivery of SPA-ZC 302.

12



1MRS755014

Profibus-DPV1/SPA Gateway SPA-ZC 302

Installation and Commissioning Manual

2.4.

2.5.

Additional support products

In cases where the only physical connection to the SPA bus of the protection relay
is an optical interface, a SPA-ZC 21 can be used to provide the necessary optical
interface from the SPA-ZC 302 gateway. Which variant of SPA-ZC 21 should be
used, depends on if glass or/and plastic fibers are available in the SPA bus. In
addition, it is recommended to use SPA-ZC 21 and an optical loop to the relays when
connecting several relays to SPA-ZC 302. For more information, contact your ABB
representative.

Backwards compatibility

The new gateway contains features, such as the event channel and reading multiple
binary data, affecting the configuration template format.

The gateway software version 2.0 is compatible with the old configuration template
format. In this compatibility mode, it works as an older 1.03.03 device. There are
two ways to activate the compatibility mode:

* You can download the old configuration template with the old PCT tool (Profibus
DP/SPA Gateway Configuration Tool).

 Oryou can select Download as > v1.02 in the new PCT tool version.

The new PCT tool automatically converts and saves the old configuration template
to the new format.

ﬂ The new template file format is not compatible with the old PCT
tool.

13
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3.1.

Installation

This chapter describes the mechanical installation of the SPA-ZC 302 module. It
also describes the electrical configuration of the gateway for different SPA bus types
and supply voltages. For additional information, refer to Chapter 7. Technical data
and Chapter 8. Maintenance and service.

Application

A Profibus-DPV1/SPA gateway is used to connect SPA bus devices to the Profibus
DP fieldbus.

OPC Clients ¢

Ethernet 1
Local Area Network

; | Engineering =
: 1_'— Station A

Ethernet 2 OPC Server I
Controller Network |

F

Profibus
Master

Profibus DP

SPA RS-485 —< SPARS-232 =

SPA-ZC 302 SPA-ZC 302
! P |
SACO 64D4 Annunciator _ REF 54x
Multiple SPA slave modules Single SPA slave

[

I SPA-ZC 302
|

| — 'I SPA-ZC 21 :
i | Ty |

Multiple SPA slaves on SPA Loop connection

A050290

Fig. 3.1.-1 Conceptual picture of a typical system setup

15
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3.2. Mechanical installation
1. Fix the module with two screws on the bottom or wall of the cubicle, near the
protection relay that the module will be connected to. Notice the length of the
SPA connection cable.
2. Ensure that the DIP switch configuration of the module is correct, see Section
3.3.3.3. DIP switch configuration.
3. Connect the SPA communication cable between the SPA relay and D-connector
of the SPA-ZC 302, for details, see Fig. 3.1.-1. If you connect several relays, use
a SPA-ZC 21 on the SPA-ZC 302’s SPA port and build an optical loop
connecting all the relays.
4. Connect the twisted pair cable to the Profibus D-connector of the SPA-ZC
302.The other end of the cables is connected to a Profibus DP master.
Profibus requires that the last device in the daisy chain must be
@ terminated.
3.3. Electrical installation
3.3.1. Auxiliary power connection
Voltage range for the external power connection (Uaux) is 110-240 VV AC/DC.
Table 3.3.1-1 Screw terminal of Uaux connection
Screw terminal AC DC
1 N
2 L +
In addition, there is an earthing screw for the protective earth conductor beside the
screw terminals in the casing. Refer to Fig. 2.2.-1 for the location of the auxiliary
power connectors.
3.3.2. Profibus DP version 1 bus interface
The Profibus DP version 1 bus interface of the gateway consists of the following
parts:
A 9-pin D-type sub miniature connector
» Two rotary switches for address selection
 Four LEDs for status and diagnostic purposes
3.3.2.1. RS-485/Profibus DP version 1

16

The Profibus DP version 1 interface is able to handle serial communication with RS-
485 levels.

It is recommended to use a Profibus connector that does not cover DIP switches or
status LEDs. Some of the commonly used connectors can easily be flipped to face
right or left.
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The pin numbers of the RS-485/Profibus DP version 1 bus connection are presented
in Table 3.3.2.1-1.
Table 3.3.2.1-1 Profibus DP version 1 connector
Pin Usage
Housing Shield, connected to Power earth
1 Not connected
2 Not connected
3 B-line, Positive RxD/TxD according to RS-485 specification
4 RTS, Request to send
5 GND BUS, Isolated GND form RS-485 side
6 +5V BUS, Isolated +5V from RS-485 side
7 Not connected
8 A-line, Negative RxD/TxD according to RS-485 specification
9 Not connected
3.3.2.2. Address selectors

The addressing of the device can be done in two ways:

 The first and easiest way is to select the slave address using the rotary switches
that are located in front of the device, see Fig. 3.3.2.2.-1. Using this method, the
addresses 0-99 can be selected.

« If the rotary switches are set to address 0 (zero), the slave address can be set by
using the Profibus Configuration Tool (PCT), see Section 5.2. Starting PCT.

St I 1T R

Off-line  Acyclic Profibus Address Profibus-DP |

On-line  Diagnostics Low digit / High digit RS485 .
ﬂ SPA INTERFACE P
\ RS485 | 0000 | 00001111

|
i
L | 0000 | 01100000 '
RS232 | 0111 | 00000000 [
+8V XXXX | XXXTXXXX i
Conff | 1111 | 00000000 J

1234 12345678

A050339

Fig. 3.3.2.2.-1 Address selectors in SPA-ZC 302

If no address is set, use the default address 125. Changing of the Profibus address
requires reboot of the gateway, that is through power off/on, or by changing to
application mode from the configuration mode using the A1 DIP switch, see Section
3.3.3.3. DIP switch configuration.

17
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3.3.2.3. Profibus DP communication speeds

Table 3.3.2.3-1 Communication speeds

Baud rates supported

9.6 kbit/s
19.2 kbit/s
45.45 kbit/s
93.75 kbit/s
187.5 kbit/s
500 kbit/s
1.5 Mbit/s
3 Mbit/s

6 Mbit/s

12 Mbit/s

The communication speed is automatically detected by the gateway when it is
connected to the Profibus.

3.3.3. SPA bus/configuration interface

The gateway is provided with a 9-pin D-connector. The interface types are RS-232,
RS-485 or TTL. The DIP switches located on the connector board beside the
D-connector are used to set signal types and supply voltage.

Table 3.3.3-1 SPA bus connector

Pin Usage
Housing Shield connected to power earth

1 RS-485 A-line, Negative RxD/TxD

RS-485 B-line, Positive RxD/TxD / RS-232C TxD / TTL RxD

RS-485 RTS A (-) / RS-232C RxD / TTL TxD

RS-485 RTS B (+)

Signal ground

Not connected

Signal ground

+5 V supply voltage source

Olo|N|oOOa|bh|lw(N

+8 V supply voltage source

3.3.3.1. Communication settings

The SPA settings are 7 data bits, 1 stop bit and even parity. The SPA interface
settings shall be the same regardless if RS-485, RS-232 or TTL level is used.

18
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3.3.3.2. SPA bus communication speeds
Table 3.3.3.2-1 Communication speeds
Baud rates supported
1.2 kbit/s
2.4 kbits/
4.8 kbit/s
9.6 kbit/s
19.2 kbit/s
38.4 kbit/s
The SPA baud rates can be set through the Profibus-DPV1/SPA Configuration Tool
(PCT), to match the connected relay. If several relays are connected, they all use one
common baudrate.
3.3.3.3. DIP switch configuration

The SPA interface is configured by using DIP switches located beside the DSUB9
connectors. To select the correct DIP switch number, follow the instructions in
Table 3.3.3.3-1 and see Fig. 3.3.3.3.-2:

switching on the new settings when changing the interface type.
Only one interface type must be active at a time. The state of the DIP
switches can be changed without turning the power off.

f For the safety, set the active DIP switches to OFF position before

The smaller group of DIP switches is referred to as group A, and the
ﬂ larger group as group B, see Fig. 3.3.3.3.-2.

fim = D

SPA
RS485
RS232

TS

A050336
Fig. 3.3.3.3.-1 DIP switch configurations A1-4 and B1-8

The DIP switches A1-4 and B1-8, see Fig. 3.3.3.3.-1, are described in
Table 3.3.3.3-1

19
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Table 3.3.3.3-1 DIP switch configurations Al1-4 and B1-8

DIP switch no

Interface type

Description

B5-8 RS-485 This interface type is supported by most protection relays
B4 RS-485/ TTL/ This interface type is used for powering additional
+ 8 Volt supply |adapters, such as SPA-ZC 21(RS-485/TTL to optical
voltage converter for the SPA bus)
B2-3 TTL level This interface type is supported for example by the SPAJ
140 C protection relay
B1 - DIP switch B1 is not connected
A2-4 RS-232 This interface type is necessary when configuring the
gateway and is also supported by some protection
relays.
Al Configuration DIP switch Al puts the gateway into configuration mode.
mode This switch must be ON whenever communication is

required between PCT and the gateway. When this
switch is ON, the RS-232 interface type shall also be
selected

In the gateway version 2.0, the DIP switch configuration has changed from the
version 1.03.03, see Fig. 3.3.3.3.-2 for the new ON-OFF direction.
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Fig. 3.3.3.3.-2 DIP switch configurations A1-4 and B1-8

A050292

communication port in the SPA slave, the Module status word

@ If the new DIP switch configuration requires changing of
]

indicates SPA off-line status (bit 3=1). Refer to Section 5.1. Program
overview for more information about the Module status word.

With several relays in the SPA loop, you actually set the interface between SPA-ZC
21 and SPA-ZC 302, for example RS 485, and activate the +8V supply to SPA-ZC
21.
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3.3.3.5.
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RS-485/SPA bus cable

SPA-ZC 302 SPA device, RS-485
1 1
2 2
3 3
4 4
7
9 9
9-pin female D-connector 9-pin male D-connector
cable485_a

Fig. 3.3.3.4.-1 Interface cable coupling when using RS-485 (Order

number:1MRS120541)

Table 3.3.3.4-1 Pin numbers of the SPA bus/RS-485 connection

Pin

Usage

DATA A, data signal pair, signal A (+)

DATA B, data signal pair, signal B (-)

RTS A, request to send signal pair, signal A (+)

RTS B, request to send signal pair, signal B (-)

GND, signal ground

O N|DWIN|PF-

+8V, optional power supply from the SPA-ZC 302

RS-485/SPA bus cable

SPA-ZC 302 SPA device, RS-485

1

2

9-pin female D-connector —i

Terminal Block

A050352

Fig. 3.3.3.5.-1 Interface cable coupling when using RS-485 with, for example,

REX 521, RE_610, SACO annunciator unit

Table 3.3.3.5-1 Pin numbers of the SPA bus/RS-485 connection

Pin Usage
1 DATA A, data signal pair, signal A (+)
2 DATA B, data signal pair, signal B (-)
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3.3.3.6. TTL/SPA bus cable
SPA-ZC 302 SPA device, TTL
2 2
3 3
7 7
9 9
9-pin female D-connector 9-pin male D-connector
cableTTL_a
Fig. 3.3.3.6.-1 Interface cable coupling when using TTL (Order
number:1MRS120541)
Table 3.3.3.6-1 Pin numbers of the SPA bus/TTL connection
Pin Usage
2 RXD, data from SPA bus device
3 TXD, data to SPA bus device
7 GND, signal ground
9 +8V, optional power supply from SPA-ZC 302
3.3.3.7. RS-232/SPA bus cable

SPA-ZC 302 SPA device, RS-232
2 2
3 3
5 5
9-pin female D-connector 9-pin male D-connector
cable232_a

Fig. 3.3.3.7.-1 Interface cable coupling when using RS-232 (Order
number:1MRS120541)

Table 3.3.3.7-1 Pin numbers of the SPA bus/RS-232 connection

Pin Usage
2 TXD, data to SPA bus device
3 RXD, data from SPA bus device
5 GND, signal ground
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3.3.3.9.

3.4.

3.4.1.

3.4.2.
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SPA loop

When you connect more than one SPA relay to the same gateway, the relays should
be connected by means of an optical SPA loop, see Fig. 3.3.3.8.-1.

SPA-ZC 302

o

A050338

Fig. 3.3.3.8.-1 Multiple SPA slaves in SPA loop connection

Configuration cable

You can connect the gateway and the PC by using a standard straight serial cable or
the SPA cable that comes with SPA-ZC 302 as a configuration cable.

Installing Profibus-DPV1/SPA Configuration Tool

System requirements

The Profibus-DPV1/SPA Configuration Tool (PCT) user interface requires a 32-bit
version of Microsoft Windows® (Windows NT/2000/XP/98). A serial port must
also be available on the PC.

Necessary proprietary cables are included in the SPA-ZC 302 configuration
package, see ordering information in Section 2.3.

Installing the software

To install the PCT software, you need a working directory on a hard drive with full
read/write access. The software can also be run directly from the CD.

The installation program will install the required files on the hard drive while giving
you information about the progress. It also performs the required changes to the
Windows registration for the installed files.

Insert the CD-ROM into the CD-ROM drive (for example drive D:). The installation
will start automatically if the Autorun option is active on your PC. If it is not active,
start the installation by selecting Run from the Start menu, and defining the
command line in the Run dialog, as shown in Fig. 3.4.2.-1 below, or by double-
clicking the PCT.EXE file in Windows Explorer.
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ron 21 x|
Tvpe the name of a program, folder, docurment, or
Internet resource, and Windows will open it For you,
Open: | D:\PCT.EXE |
] o Cancel | Browse, .. |
sl _run_a

Fig. 3.4.2.-1  PCT installation

When the installation program has started, follow the step-by-step instructions given

on the monitor.
To view the manuals, you can use the free Adobe Reader software.

ﬂ Adobe Reader 7.0 for Windows XP and Windows 2000 SP2 are
included in the installation CD. To install the Reader, start the
Adobe Reader installation file located in the ADOBE READER 7.0
folder on the CD. If your operating system is older than Windows
XP or Windows 2000 SP2, you have to install the Reader by
downloading the appropriate version for the operating system from
http://www.adobe.com.
3.4.3. Uninstalling the software

By using the Add > Remove Programs command in the Control Panel, it is possible
to uninstall the software from the PC. The Control Panel is opened by selecting
Settings > Control Panel from the Start menu.

@ If you uninstall the software, the gateway configuration data is
]

removed from the computer. If you want to save the configuration
data, you need to make copies before uninstalling.

25
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4.1.

Commissioning

This chapter describes the commissioning of the gateway by using Profibus-DPV1/
SPA Configuration Tool (PCT).

The commissioning phase includes following actions in short:

1. Set the gateway to configuration mode.

2. Connect the PC containing the Profibus-DPV1/SPA Configuration Tool to the
gateway.

3. Open a standard configuration and define the SPA addresses and scaling. In a

multislave project, you can import several standard configurations to the

different slave sections in PCT. For more information, refer to Section 4.3.

Multislave configuration.

Save the configuration with a new name.

Download the configuration and, optionally, the source to the archive.

Connect the gateway to the protection relays and start it up.

Connect the gateway to the PC again and upload the configuration.

Verify that the appropriate In Use flags are checked.

© N O

See the following sections for details about the actions.

Hardware set-up

The gateway and the PC hardware must be connected and set up properly in order to
perform a successful configuration of the gateway.

If the ordered product package is a SPA-ZC 302-AA or BA, the provided connection
cable (LMRS120541) can be used for configuration purposes if a gender change
adapter (female-female) is used for the PC connection.

Connect the cable between the COM port on the PC and the SPA protocol port on
the gateway device. If your PC contains only USB ports, you need an USB to COM
port adapter, which can be purchased from any well-equipped computer store.

K—ﬂﬂ To RS-232 PC COM port

SPA-ZC 302
gateway

ConfigSetup_a

Fig. 4.1.-1 Configuration arrangement principle

The SPA protocol port setting must be set to RS-232 using the DIP switches as
described in Section 3.3.3.3. DIP switch configuration.
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Ensure that PCT is set to use the serial port that the cable is connected to. Check this
by selecting Settings > COM in the main menu in PCT. For details about PCT, see
Section 5.2. Starting PCT. PCT adjusts the COM port settings of the PC
automatically.

4.2. New configuration

28

Before a new configuration is started, you have to select a standard configuration
template from the configurations described in Chapter 6. Standard configuration
templates. Which one you should select, depends on the requirements of the system
in which the protection relay and the gateway device are installed.

When you have selected the standard configuration template, you have to define the
protection relay dependent data and commission the gateway by following the
instructions below:

1. Start the PCT and open the selected standard configuration template by
selecting File > Open in the main menu. Select the wanted standard
configuration template and click Open, or just double-click on the template you
want.

open 2|

Look, ir: I_]' Templates j - l:jg -

Basicl_103.pcf Medium4_103.pcf RE¥S21_High
Basicz_ref_103pcf MediumS_103,pcf RE¥S21_Med
Basic2_res_103.pef Mediurmé_103.pcf SACOLEA3.p

Basic3_103.pcf
Basicd_103.pef
Mediurml_103,pcf
Medium2_103.pef
Medium3_103.pef

Kl

New_REF&10.pcf
Mew REME10.pef
RETS#_Basic.pcf
RETS4_Contral.pef
RETS4 MULTL pef

SACCE4D4p
SPAD34EC3.|
SPAL34L . pef

i

File narne: || Open I
Filez of type: IF'n:ufibus DP/SPA Gateway Configuration Filej Cancel |
&

A050341

Fig. 4.2.-1 Opening the configuration template

Define the address of the SPA slave connected to the gateway by selecting Slave >
Set Address and type in the address in the SPA Slave Address dialog,
see Fig. 4.2.-2.

x
SPA Slave Address: |1
coot_|

Fig. 4.2.-2 Setting the SPA Slave Address

A050295



1MRS755014

Profibus-DPV1/SPA Gateway SPA-ZC 302

Installation and Commissioning Manual

If the connected SPA slave is a SPACOM relay with several modules and addresses,
such as SPAD 346 C or SACO 64D4, the standard configuration can have several
addresses defined in it already. In this case, PCT automatically creates a tabbed page
for each address or slave module.

If you do not have a suitable standard configuration or you have a standard
configuration made for one of the modules, you can do as follows:

1. Open the configuration.

2. Add the slaves for each module.
3. Import the configuration again for each slave as if there were several relays
connected.

Select a signal in the Template info field in the PCT and click the Edit button, or
double-click on the signal. A dialog is opened where you can set the SPA slave
address for that signal, see Fig. 4.2.-3 number 1.

Analog Input x|

D escription: |In|:|ut 1

Slave Address: |1 1

ChiCatOno [0 [ <] [i

Scaling: |1 2

Size: |32 Bit j
Optionz

’7|7 In s ™ Pricrity

Analog nput2_a

Cancel |

Fig. 4.2.-3 Analog Input settings

4. When you have defined the SPA slave address or several addresses, the scaling
factors should be defined for necessary signals. The signals that need to be
defined are pre-dominantly measurement signals that get their input from
measurement transformers and sensors. Scale the necessary signals by selecting
a signal in the template info section of the PCT and click the Edit button, or by
simply double-clicking on the signal. A dialog is opened where you can define
the scaling factor for that signal, see Fig. 4.2.-3 number 2. To calculate the value
on the SPA bus, use the following formula:

Profibus_Value
Decimal_place

SPA Value =

)

(parameter scaling x 10

To calculate the value on Profibus, use the following formula:

Profibus_Value = SPA_Value x (parameter scaling x 10De°imal—place)

The default value is 1.
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4.3.
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5. Once you have defined a configuration, you can save, use, and re-use it to
connect the same type of protection relay or a system of multiple relays to a
gateway. The configuration is preferably saved on a different location on the
disk, and with a different name than that of the standard configuration template.

6. Define the Profibus address by either setting the address selectors on the front of
the gateway to the selected address, or by setting the selectors to zero and
defining the selected Profibus address in PCT. For details, see Section 5.2.
Starting PCT. To read the address selectors correctly, the gateway should be
held so that the Profibus DP connector is situated on the left side of the address
selectors. If the address is set by using the address selectors, the gateway must
be restarted before the address takes the effect. The address selectors are marked
as High Digit or Low Digit in the gateway.

Multislave configuration

If several relays are connected, you may have a ready made configuration template
for the multislave system that consist of several slaves. Otherwise, you should start
from the configuration template matching the first relay. Then you can add the other
slaves and import the configurations to each slave.

If you open the configuration template matching the whole system, you just have to
set the automatically created addresses of each slave.

If you do not have a ready made multislave configuration, do as follows:

1. Open the single slave configuration template and set the address of the first
relay by selecting Slave > Set address, see Fig. 4.3.-1.

x
SPA Slave Address: |1
cocs_|

Fig. 4.3.-1 Setting SPA Slave Address

2. Select Slave > Add to add all the slaves in your multislave system.

A050295

When all the slaves are added, you have one tabbed page for each slave, see
Fig. 4.3.-2. The first page already includes the opened configuration template and
has the address that was just set.

— Template Info

Tatal Template Size: Ig-| Input Area Bytes |2 Output Area Bytes

el

I 5Iave2| Slave3| Sla\fedl

[Analog_Input] -
O0fs Description InUse Pr S1 ChCatDno  Scale
884 Spa device status = IRF 1H 1 24015 1.88
888 Current IL1 in amperes 1H 1 28811 1.84@

A050340

Fig. 4.3.-2 Template info field with tabbed pages for the different slaves
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4.4.

3. Select the next tabbed page representing the second slave.
4. Select Slave > Import to open a dialog for importing the configuration
template, see Fig. 4.3.-3.

open (x|
Look in: I_]' Templates j - £ B2

Basicl_103.pcf Medium4_103.pef RE®S21_High
Basic2_ref_103.pef Mediums_103.pef RE¥S21_Med
Basic2_rex_103.pef Mediumé_103.pef SACO16A3.p
Basic3_103.pcf New_REF&10,pcf SACCE4D4p
Basic4_103.pef Mew REMB10.pcf SPADI4EC3.|
Medium1_103,pcf RETS4_Basic.pcf SPAL34L pef
Mediurm2_103.pcf RETS4_Contral.pcf

Medium3_103,pcf RETS4_MULTL pcf

File name: || Open I
Files of type: IF'n:nﬁbus DP/SPA Gateway Configuration Filej Cancel |
s

A050341

Fig. 4.3.-3 Importing the configuration template

5. Inthe Import dialog, select the configuration matching the second relay.

6. Select Slave > Set address to set the address of the second relay, see Fig. 4.3.-1.

7. Repeat these steps for all the slaves and always check the total template size
while adding slaves and importing their configurations.

After each import, remove the unnecessary data items. It helps you to keep total
template size under 240 bytes and removes unnecessary profibus traffic.

side, even in case the slave does not contain these specific data

ﬂ All the data included in the template is transferred in the profibus
items.

The response time is highly dependent on the number of the
connected SPA slaves and the size of the configuration. For more
information, refer to Section 8.4.1. Gateway diagnostics.

When verifying signals in a multislave system, all the relays must be connected.
Otherwise the In Use flags of an entire slave might be deactivated.

Downloading configurations

When a configuration is defined, it is time to download it to the gateway by
following the instructions below:

1. If you have downloaded the configuration file directly after the configuration
definition described in the preceding Section 4.2. New configuration, jump to
step 2. In other cases, start the PCT and open the selected standard configuration
template by selecting File > Open in the main menu, and by double-clicking on
the wanted standard configuration template name.
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2. Ensure that the correct COM port is selected from the Settings > COM menu in
PCT.

3. Also ensure that the gateway is in configuration mode. Configuration mode is
enabled by using the DIP switches on the front of the gateway, see Section
3.3.3.3. DIP switch configuration.

4. Select Device > Download configuration in the main menu. The configuration
is now downloaded and a confirmation dialog is displayed. Click OK to confirm
the download, see Fig. 4.4.-1.

success N, x|

@ Configuration download Ok [+2,00]

A050353

Fig. 4.4.-1 Configuration download succeeded

This step is optional but it is a good practice to also download the configuration
source to the gateway. In this way the gateway always contains all the necessary data
that can be used in the future. The configuration archive can be downloaded as such
or compressed to a zip file. After that, select Device > Download Archive in the
main menu and a file selection dialog is opened. Select the saved configuration that
has been made for the gateway “<filename>.pcf” and click Open. When this is done,
the archive will be downloaded to the device and the a confirmation dialog is shown,
see Fig. 4.4.-2. Click OK to confirm the archive download. For more information
on LEDs, see Section 8.4. Troubleshooting.

Success x|

@ archive download Ok

Archewlwm_a

Fig. 4.4.-2 Archive download succeeded

The archive is stored in the device until another archive is downloaded and the new
archive overwrites it.
5. In order to verify the signals that are actually read from the protection relay:

» The configuration is uploaded after the first start-up with the protection relay
connected.

» The state of the In Use flag is checked.

For details on how to do this, see Sections Section 4.7. In Use flags.
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4.5.

4.6.

Gateway initialization

When the gateway is set into application mode from the configuration mode by
using the DIP switch, see Section 3.3.3.3. DIP switch configuration, the gateway
starts to go through the configuration one parameter at a time to verify that the
source parameter is available in the protection relay. If a parameter does not answer
on the data request from the gateway, the In Use flag will be reset, see Section 4.6.
Time synchronization.

The gateway polls only the parameters that have the In Use flag set. In the profibus
side, parameters which cannot be read from the SPA device report the value OXFF,
OxFFFF or OXFFFFFFFF according to the size of the data, except for the values that
are updated by events that have the value OxOF.

The state of the In Use flags is stored into the non-volatile memory. This means that
supply power interruption will not affect the configuration and the gateway will start
up normally.

The process data is valid when the gateway mode bit indicates application mode and
SPA initializing is zero. There is a separate data-valid bit for each slave. Bit 3 must
be zero (SPA On-line). If bit 5 indicates a configuration warning, some of the data
is invalid (unavailable). The unavailable items are reported with OxF in the Profibus
message. For the valid process data, the SPA device status (IRF) information should
indicate no errors. The initial states of the digital inputs are polled from the SPA
slave. After this, if declared, events are used to update the inputs.

The SPA event mask has to be open for these signals. Only one SPA
master can read events from the SPA slave at a time.

Time synchronization

To enable the Time synchronization feature of the gateway, a
Profibus-DPV1 master that is capable of writing acyclic messages to
specific slots must be used. It is important that the protection relay
does not receive time synchronization signals from more than one
source.

The time synchronization feature of the gateway requires that the internal clock of
the gateway is set. The gateway time is then used to synchronize the protection relay.
Set the gateway clock by writing the date to slot O of the acyclic output and the time
to slot 1 according to Table 4.6.-1.

33



SPA-ZC 302 Profibus-DPV1/SPA Gateway 1MRS755014
Installation and Commissioning Manual
Table 4.6.-1 Time synchronization formats
Slot |Index |Name Size Description Range
0 0 |Year WORD Year in format-yyyy- 0-9999
4 |Month BYTE Month in format -mm- 1-12
5 |Day BYTE Day in format -dd- 1-31
1 0 |Milliseconds |WORD Milliseconds in format -sss- 0-999%)
1 |Seconds BYTE Seconds in format -mm- 0-59
4 |Minutes BYTE Minutes in format -mm- 0-59
5 |Hours BYTE Hours in format -hh- 0-23
1)When the gateway detects a change in this field, it will update the internal date and
time counter to be used when synchronizing the SPA slave device. The time
synchronization is enabled by selecting the option in PCT, for details see
Section 5.4.7.1.
4.7. In Use flags
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The In Use flags, that are present on all signals, indicate if the signal is available in
the protection relay.

The In Use flag can be handled in two ways:

» The gateway automatically detects what signals are present in the protection relay
and sets or resets the flag accordingly.

* The flag can be set manually by setting, or resetting, the check box in the signal
dialogs.

It is recommended to let the gateway determine the signals that are available in the
protection relay.

If a signal is read from the protection relay, the gateway will report the actual value
of the signal on Profibus. If asignal is not read from the protection relay, the gateway
will report a value of OxFF (255), OXFFFF (65 535), or OXFFFFFFFF (4 294 967
295) depending on the data type of the signal on Profibus.

This mechanism makes it possible to use the available standard configuration
templates in a flexible way, by selecting a template that contains the necessary
signals. If there are signals defined in the template that are not present in the
protection relay, the maximum value for the data type of the signal is reported by
default. In other cases the signal’s actual value is reported.

If you do not want the OxFFFF values to cause unnecessary traffic
@ on the profibus side, you should remove all the parameters that could
2 not be found in the relay from the configuration and download it
again.This changes the data size on the profibus side. The master
application must be updated accordingly.
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5.1.

5.2.

Profibus-DPV1/SPA Gateway Configuration Tool

Program overview

With the Profibus-DPV1/SPA Gateway Configuration Tool (PCT) you can perform
the following tasks:

» Download and upload the configuration file from the gateway

« Load stored configurations for the gateway

* Save configurations for the gateway

Upload and reset SPA diagnostics

Configure SPA protocol parameters

Set default Profibus node address

« Set priority of SPA messages, decimal place for analog values and scaling for
analog values

Create Indirect SPA messages
Global disabling/enabling of event polling
Create multislave configurations by using several singleslave templates

* Remove slaves or parameters to keep the total configuartion template size smaller
than 240 bytes

Starting PCT

The PCT is started by clicking Start and selecting Programs > ABB > Profibus
DPV1 SPA Gateway SPA-ZC 302 > Profibus DPV1 SPA Gateway SPA-ZC 302
Configuration Tool.
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5.3. Main view
_,’-}_RETSci_MULTI.pcf— Profibus DP/SPA Gateway Configuration Tool — |0l x|

File Device Settings

Slave View Help -—— 3

s IEE R

)

— 5P Configuration

-

— Template Info
SPA Baudrate: IE!EDIJ 'I Total Template Size: |233 Input Area Bytes Ig Output Area Bytes
6
SP& Reply Timeout: |5|j ms . Slave2| S|E'V'33I SI‘3“"3‘1'| /’f
[Analog_Input] -
SPA Idle Time: |5 ms 0fs Description Inllse Pr S1 ChCatDno  Scale
884 Spa device status = IRF 1H 1 115 1.88
SPA Com Retrycaunt: |2 888 Tap changer position 1H 1 186128 1.88
812 Current IL1 in amperes HU side 1 H 1 280811 1.88
Global Pall Intervak I— - 816 Current IL2 in amperes HU side 1 H 1 28812 1.88
3000 828 Current IL3 in amperes HU side 1 H 1 28813 1.88
[ Global Event Pol 824 Current IL1 in amperes LV side 1H 128211 1.88
828 Current ILZ? in amperes LU side 1H 1 28212 1.88
[ Time Synchrorization Support 832 Current IL3 in amperes LU side 1N 1 28213 1.88
o 836 Current Io in amperes HU side 1H 120111 1.88
I Date Synchronization Support s 840 Current Io in amperes LU side 1 H 1 28311 1.00
. : : _'_____.-"" @44 Uoltage UL1_U12 in kilowolts HU 1 H 1 28411 1.08
—Prnflbustonhguratmn‘/ A48 Uoltage UL2_U23 in kilovolts HU 1 H 1 28412 1.00
Default Profibus Adr. @852 Uoltage UL3_U31 in kilovolts HU 1 H 1 28413 1.88
Ftaull Frelibus Adr. |”7 856 Uoltage UL1_U12 in kilovolts LU 1 H 1 28511 1.80
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Edit Femove Add Mew Indirect SPA Mezzage |

Ready

[ m [

Fig. 5.3.-1 Main view of the Profibus DP/SPA Gateway Configuration Tool

5.
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4.

The PCT main view consists of the following fields, see Fig. 5.3.-1:

NGO~ wWDd E

Title Bar

Main Menu

Toolbar

SPA Configuration field
Profibus Configuration field
Template info field with one tabbed page for each slave
Indirect SPA Messages
Total template size field

PCT menus

This section describes the main menu, the submenus and commands that are
available in PCT.

A050294
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5.4.1.

5.4.1.1.

5.4.1.2.

5.4.1.3.

5.4.1.4.

5.4.1.5.

5.4.2.

File menu
The File menu contains the following functions:

Qpen...

Save Cirl+5
Save As...

Export 5

Frint Cirl+F

Exit

A050342

Fig.5.4.1.-1  File menu

Open

To open a ready-made configuration file in the PCT, select File > Open in the main
menu, or click on the corresponding icon in the toolbar. Select the wanted
configuration in the dialog, and click Open. The selected configuration will be
shown in the Template info field on the right. You can modify the configuration by
selecting the signal that you want, and clicking Edit, or by double-clicking on the
signal. For details see Section 5.4.8. Template info.

Print

To print, select File > Print in the file menu, or click on the printicon in the toolbar.
A print dialog is opened in which you can select printing options. Confirm the dialog
by clicking OK. To cancel, click Cancel to close the dialog.

Save / Save As

To save the configuration made in the PCT, select File > Save in the main menu or
click the corresponding icon in the toolbar. If you want to give the configuration a
new file name, select File > Save as in the main menu. Type the new name of the
configuration in the field and click Save.

Exit

Select File > Exit in the main menu to exit the program. If a document with unsaved
changes is open, a dialog will prompt you to save the changes first.

Export csv

To export the template file to Excel, select File > Export csv. The .csv format
contains all the necessary information for documenting your project and can also be
useful when engineering the master application.

Device menu

In the Device menu you can select between different download and upload
alternatives or check the firmware version of the device, see Fig. 5.4.2.-1.
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All operations in this menu are possible to perform only when the gateway is in
configuration mode. For details, see Section 8.4. Troubleshooting.
_ Device
Download Configuration to device
Download Configuration to device as...  #
[ Upload Configuration From device
Download Archive to device
Upload Archive From device
Upload Diagnostics From device
Clear Diagnostics
Get Firmware Version From device
A050337
Fig.5.4.2.-1  Device menu
5.4.2.1. Download/upload configuration (as)
To download or upload the configuration file of the gateway, select Device >
Download Configuration (as) or Upload Configuration in the main menu. By
selecting Download Configuration to device as v.1.02 or 2.0, you can download
the configuration template to the old gateway version by using the new tool. For
details see Section 4.4. Downloading configurations.
The old gateway does not support event channel or packed data
5.4.2.2. Download/upload archive
The archive is intended for storing the configuration source file of the gateway for
future use. It is however recommended that the configuration is also stored in some
other file for safety.
To download or upload the archive of the gateway, select Device > Download
Configuration or Upload Configuration in the main menu. For details see Section
4.4. Downloading configurations.
5.4.2.3. Upload diagnostics
The gateway contains a supervision functionality that can be uploaded when it is
necessary to verify or check the condition of the gateway. To upload, Select Device
> Upload Diagnostics in the main menu.
5.4.2.4. Clear diagnostics
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To clear and reset the diagnostics described in Section 5.4.2.3, select Device > Clear
diagnostics in the main menu.



1IMRS755014 Profibus-DPV1/SPA Gateway SPA-ZC 302
Installation and Commissioning Manual
5.4.2.5. Get firmware version
To check the firmware version of the connected gateway, see Fig. 5.4.2.5.-1, select
Device > Get Firmware.
Firmware x|
@ Firrnware version : 2,00 build 1
A050355
Fig. 5.4.2.5.-1 Checking the firmware version
The gateway must be in configuration mode when you get the firmware version.
5.4.3. Settings
In the Settings drop-down menu, you can select serial port COM1, COM2, COM3
or COM4.
Settings
CoM Pork B _iom 1
v COMZ
COM3
Satlings_a COM4
Fig.5.4.3.-1  Settings menu
5.4.4. Slave menu

In the Slave menu, you can change the slave address for all the signals
simultaneously. If you want to change the slave address for all the signals, select
Slave > Set Address from the Slave menu, see Fig. 5.4.4.-1. For more information,
see Section 4.2. New configuration and Section 4.3. Multislave configuration.

| Slave
. Add
Remove
Set Address
Pricritize g
Impork

A050297

Fig.5.4.4.-1  Slave menu
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Slave Menu includes the following commands:

Add Add a slave

Remove Remove a slave

Set address Set address to the added slave

Prioritize Prioritize a certain slave, can be either on or off
Import Import the configuration to a certain slave
View

In the View drop-down menu, you can select whether to show or hide the toolbar
and the status bar in the window.

Wiew

v Toolbar

v Skatus Bar
Refresh

‘whw_i

Fig.5.4.5.-1  View menu

Refresh

To refresh the information in the Template info field, select View\Refresh in the file
menu, see Fig. 5.4.5.-1. The configuration file that is currently open in the Template
info window is reloaded from the disk.

Help

In the Help menu you will find the About function that shows general information
about the PCT.

Configuration options

SPA configuration

The SPA Configuration field is found on the left hand in the main window, see Fig.
5.3.-1, number 4. Here you can select and define several options when you load an
already saved configuration file, see the definitions below:

SPA Baudrate In this drop-down box, you can select the baudrate to be used by
the gateway when communicating with the protection relay. The
default value is 9600 bauds.

SPA Reply In this text field, you can define the value that will be used by the

Timeout SPA gateway as a timeout value. Valid timeout values are 10 ms
to 500 ms. Default value is 50 ms.

SPA Idle Time In this text field, you can define the Idle time. Idle time is the time
that the gateway will wait before sending the next SPA message
when receiving the response of the previous sent SPA message.
Valid Idle time values are 5 -10 ms. The default value is 5 ms.
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SPA Com Retry Inthis text field, you can define how many times the gateway will

Count retry sending a message when failing to get a valid response before
continuing with the next message. Valid values are 1-32 times.
The default value is 2.

Global Poll In this field, you can define the idle time of event based updating

Interval of digital inputs. If the SPA events are present in the SPA slave,
then they are automatically polled with 100 ms interval until the
SPA slave has not got anymore events. After this, the gateway
checks the SPA slave event buffer with the time interval specified
in this parameter. Default value is 3000 ms.

Global Event By selecting the check box, you can enable polling of SPA

Poll Events.The events will be stored into the Event buffer. When
disabled, the polling of events will not be performed at all. Event
functionality is used by some standard configurations for updating
the state values. For details, see Section 6.3. Usage and purpose of
SPA protocol events.

Time By selecting the check box, you can enable the synchronization of

Synchronization the SPA slave device. If it is enabled, it will be necessary to

Support provide the gateway with the correct time. If the time
synchronization is disabled, the gateway will not synchronize the
SPA slave devices attached to the gateway.
This function requires a Profibus DP version 1 master which is
capable of index/slot addressing of acyclic messages.

Date By selecting the check box, you can enable the synchronization of

Synchronization the SPA slave device. If it is enabled, it will be necessary to

support provide the gateway with the correct date. If the Date
synchronization is disabled the gateway will not synchronize the
SPA slave device attached to the gateway.
This function requires a Profibus DP version 1 master which is
capable of index/slot addressing of acyclic messages.

5.4.7.2. Profibus configuration

In the Profibus Configuration field in the main window, see Fig. 5.3.-1 number 5,
you can modify the following options:

Default
Profibus Adr.

Decimal Place

In this text field, you can configure the default Profibus Node
Address of the gateway. Valid node addresses are 1-126 for the
Profibus DP Version 1 module. A value between 100-126 is
recommended. Default address is 125.

In this text field, you can set how many decimals shall be used
when the value is passed to Profibus DP. Valid values are 0-6.
Default value is 2. (Since the SPA slave devices can use 10 integer
digits and 10 decimal digits, there will be a loss of precision when
using too many decimals digits together with integer digits.) For
details, see Section Section 5.4.8.7. Scaling of messages.
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5.4.8. Template info
The Template info is shown on the right column of the main window. To open a
template into the Template info field, select File > Open in the main menu, or click
the corresponding icon in the toolbar. The template signal list shows all the signals
that exist in the current configuration, see Fig. 5.3.-1, number 6. Use the scroll bar
on the right to navigate downwards in the signal list.
The signal types of the SPA slave devices that will be used by the gateway are
presented in square brackets in the Template info field. The signal types are the
following:
« Analog Input
« Digital Input
* Analog Output
« Digital Output
* Indirect SPA Messages
The description of the signals and their settings are presented in columns in the
Template info field.
Each SPA slaves’ data is shown on their own tabbed pages. The total template size
is shown above the tabbed pages. The maximum size is 240 input bytes or output
bytes.
To configure the settings, select a signal and click Edit, or double-click on the
signal. A dialog with configuration options will pop up. For details, see the sections
below. The templates and configuration of the signals will also be described in the
following sections.

5.4.8.1. Analog input

42

When you have opened a template with an analog input into the main window, you
can configure the settings that are shown in the Template info field as follows:

1. Select the signal you want to configure and click Edit, or double-click on the
signal.

2. Adialog is opened where you can modify the settings of that specific signal, see
Fig. 5.4.8.1.-1. The fields that you cannot configure are dimmed.

3. To save the new settings, click OK. To cancel, click Cancel to discard all the
changes.
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x|

Description: IHTD input 1
Slave Address: |1
Ch/Cat/Dino |213 || j |-|
Scaling: |1|
Size: [ 32 Bit =]
Options
’]7 In Uze [ Priority
Coreel__|
A050343

Fig. 5.4.8.1.-1 Analog Input configuration dialog

The definitions of the analog input signal settings are the following:

Signal name Description

Slave Address The slave address of the protection relay or unit

Ch/Cat/Dno The Channel (Ch), Category (Cat), and the Data number (Dno)
where the specific Analog values are read from the SPA slave
device.

Scaling Scaling factor, for details see Section 5.4.8.7.

Size The size of the analog field on Profibus DP. It can be 16 bit or 32
bit, default is 32 bit. This affects the total template size.

In Use The In Use flag indicates if the parameter was found in the
connected SPA slave device during the initialization phase. In
the Template info Field the In Use flag is marked with number
1. An unselected check box indicates that the parameter was not
found. For details see Section 4.7. In Use flags.

Priority check box By selecting the Priority check-box, you can define if the
message should be polled more frequently than other messages.
This is indicated by the letter P (prioritized) after the signal name
in the Template info field. If the signal is not prioritized the letter
N (normal) can be seen in the Template info field. The default is
N. For details, see Section 5.4.8. Template info.

5.4.8.2. Digital input

When you have opened a template with a digital input into the main window, you

can configure its se

ttings that are shown in the Template info field as follows:

1. Select the signal you want to configure and click Edit, or double-click on the

signal.

2. Adialog is opened in which you can modify the settings of that specific signal,
see Fig. 5.4.8.2.-1. The fields that you cannot configure are dimmed.

3. To save the new settings, click OK. To cancel, click Cancel to close the dialog
to discard all changes.
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Digital Input X
D escriptior: IInput 4

Slave Address: |1

Ch/Cat/Dino ID

A o = A

Datatype: IS j

Bitswitch: ID j

EventChannel: Ig

EventStart: |1

EventEnd: |2

Everityals: |-| ID ID ID
Optiong

’]7 In Use [ Priority

Cancel |

A050296

Fig. 5.4.8.2.-1 Digital Input configuration dialog

The definitions of the digital input signal settings are the following:

Signal name
Slave Address

Ch/Cat/Dno

Datatype

Bitswitch

EventStart

EventEnd

44

Description
Slave address of the protection relay or unit.

Channel (Ch), Category (Cat), and the Data number (Dno)
where the specific Digital values are read from the SPA slave
device.

Defines if the SPA data is treated as a single-bit (S), double-bit
(D), a hexadecimal value (H) or packed (P).

Defines if a single-bit is inverted or if a double-bit is swapped.
(01->10, 00 ->00).0= no swap, 1 =swap.

First event to be used when matching an Event for updating the
digital input.

Last event to be used when matching an Event for an update of
the digital input. Event End cannot exceed EventStart+3, which
means that the digital input can only be updated by the four
following events.
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EventVals

EventChannel

In Use

Priority check box

A 2-bit value to be used when updating the digital inputs when
matching an Event from the range EventStart to Event End.
That is, the event defined in the EventStart field gets the first
value and all subsequent events up to EventEnd get the
following values.

Example:

In case the settings for a digital input configuration for SPA
channel 31 are the following: EventStart = 0, Event End = 1,
EventVals = 0,1,0,0, then the events of the SPA slave device
will update the value of the digital input to the Profibus as
follows:

Profibus value

SPA eventcode | ¢ idital input

EO 0

El 1

Allows gateway to work with a device in which the parameter
channel and event channel are different.

The In Use flag indicates if the parameter was found in the
connected SPA slavedevice during the initialization phase. In
the Template info Field the In Use flag is marked with number
1. A zero indicates that the parameter was not found. For details
see Section 4.7. In Use flags.

By checking the Priority check box you can define that the
message should be polled more frequently than other messages.
This is indicated by the letter P (prioritized) after the signal
name in the Template info field. If the signal is not prioritized
the letter N (normal) can be seen in the Template info field. The
default is N. For details, see Section 5.4.8. Template info.

Digital inputs can be updated in two ways:

» By matching an event read by SPA L or B command to the corresponding events
defined in the digital input (EventStart to EventEnd).

« Polling values directly from SPA slave devices. These digital inputs should not
have any events defined in EventStart or EventEnd. If both of these fields are
zero, the digital input should be updated on a regular basis by polling the values
from the SPA slave device.
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Digital input, packed data type

If the datatype is P (= Packed), the SPA message format FirstCh/LastCh and
FirstDno/LastDno is used. The datatype numbering of Ch and Dno has to be
consecutive when the data type is packed.

The packed data type allows the gateway to read multiple binary data by using one
SPA command:

 Enabling faster updating of data, which is always polled and not updated by
events.
» Consuming less bytes on the profibus side.

This data is packed in 2 bytes in the profibus side. The first data is in bit number 0
and the second in bit number 1 and so forth.

Analog output

When you have opened a template with an analog output into the main window, you
can configure its settings that are shown in the Template info field as follows:

1. Select the signal you want to configure and click Edit, or double-click on the
signal.

2. Adialog is opened where you can modify the settings of that specific signal, see
Fig. 5.4.8.4.-1. The fields that you cannot configure are dimmed.

3. To save the new settings, click OK. To cancel, click Cancel to discard all
changes.

=
Description: IAnang Out
Slave Address: |1
Ch/Cat/Dra [ o= |
Scaling: |1
Sige: [32Bit I

A050368

Fig. 5.4.8.4.-1 Analog Output configuration dialog

The definitions of the analog output signal settings are the following:

Description Signal name

Slave Address The slave address of the protection relay or unit

Ch/Cat/Dno The Channel (Ch), Category (Cat), and the Data number (Dno)
where the specific Analog values are written to the SPA slave
device.

Scaling Scaling factor, for details see Section 5.4.8.7. Scaling of
messages.
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5.4.8.5.

Size

In Use

Priority check box

Digital output

16 bit or 32 bit that defines the size of the Analog field in the
Profibus DP, the default is 32 bit. This affects the total template
output bytes.

The In Use flag indicates if the parameter was found in the
connected SPA slave device during the initialization phase. In
the Template info field the in Use flag is marked with number 1.
A zero indicates that the parameter was not found. For details,
see Section 4.7. In Use flags.

By selecting the Priority check box, you can define if the
message should be polled more frequently than other messages.
Thisis indicated by the letter P (prioritized) after the signal name
in the Template info field. If the signal is not prioritized, the
letter N (normal) can be seen in the Template info field. The
default is N. For details, see Section 5.4.8. Template info.

When you have opened a template with a digital output into the main window you
can configure its settings that are shown in the Template info field as follows:

1. Select the signal you want to configure and click Edit, or double-click on the

signal.

2. Adialog is opened where you can modify the settings of that specific signal, see
Fig. 5.4.8.5.-1. The fields that you cannot configure are dimmed.
3. To save the new settings, click OK. To cancel, click Cancel to discard all the

changes.

Digital Output

Description: IDigitaI Cut

Slave Address: |1

Ch/Cat/Dino Ig

o = |2

[ atatype: IS

[

Cancel |

A050350

Fig. 5.4.8.5.-1 Digital Output configuration dialog

The definitions of the digital output signal settings are the following:

Description
Slave Address
Ch/Cat/Dno

Datatype

Signal name
The slave address of the protection relay or unit

The Channel (Ch), Category (Cat), and the Data number (Dno)
where the specific Digital values are written to the SPA slave
device.

Defines if the SPA data is treated as a single-bit (S), double-bit
(D) or a hexadecimal value (H).
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In Use The In Use flag indicates if the parameter was found in the
connected SPA slave device during the initialization phase. In
the Template info Field the In Use flag is marked with number
1. Anunchecked box indicates that the parameter was not found.
For details, see Section 4.7. In Use flags.

Priority check box By selecting the Priority check-box, you can define if the
message should be polled more frequently than other messages.
Thisis indicated by the letter P (prioritized) after the signal name
in the Template info field. If the signal is not prioritized the letter
N (normal) can be seen in the Template info field. The default is
N. For details, see Section 5.4.8. Template info.

Indirect SPA Messages

Indirect SPA messages are acyclic messages that are not polled cyclically but can be
used at any time. Acyclic messages are primarily intended to be used for
parametrization and other non-continuous operations.

DP version 1 must be used. This is because indirect SPA messages

ﬂ For indirect SPA messages to work properly, a Profibus master with
use the acyclic properties available only from version 1 onwards.

It is possible to add and remove indirect SPA messages by clicking the buttons in
the indirect SPA message field in the main window, see Fig. 5.3.-1 number 7.

To add a new indirect SPA message, click the Add button. An empty variable row
will be added in the indirect SPA message list. To edit the new indirect SPA
message, select the new message in the list and click the Edit button, or double-click
on the signal. A dialog where you can edit the settings pops up. The PCT assigns the
message number for the indirect SPA message. This message number is used when
configuring the Profibus master. The numbering starts from one and it follows the
row numbers of the indirect SPA messages in the PCT.

You can also remove an indirect SPA message. Select the SPA message that you
want to remove and click the Remove button.

To configure the settings of the indirect SPA messages, do as follows:

1. Select the signal you want to configure and click the Edit button, or double-
click on the signal.

2. Adialog is opened where you can modify the settings of that specific signal, see
Fig. 5.4.8.6.-1. The fields that you cannot configure are dimmed.

3. To save the new settings, click OK. To cancel, click Cancel to discard all the
changes.
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Drescription: IFieset latched output

Slave Address: |-|

Ch/Cat/Dno I-.,; j |-||:|-|

Riead it IWrite j

Static Data:

Scaling:

Options

|]7 In Usge :
i
:

Cancel |E

Fig. 5.4.8.6.-1 Indirect SPA Message dialog

The definitions of the Indirect SPA message settings are the following:

Description Signal name

Slave Address The slave address of the protection relay or unit

Ch/Cat/Dno The Channel (Ch), Category (Cat), and the Data number (Dno)
where the specific Analog values are read/written on the SPA
slave device. It must be verified that the parameter (Ch/Cat/Dno)
in question exists in the SPA slave.

Read/Write Identifies the request either W (write) or to R (read). The default
value is R (read).

StaticData (Optional) Data that is assigned the write command. There can
be many SPA write messages that always use the same static
value for example reset commands. This is only valid for write
commands. If the message is defined to be R (read), then the
StaticData is ignored.

Scaling Scaling factor, for details see Section 5.4.8.7. Scaling of
messages.

In Use The In Use flag indicates if the parameter was found in the
connected SPA slave device during the initialization phase. In
the Template info field the In Use flag is marked with number 1.
An unselected check-box indicates that the parameter was not
found. For details, see Section 4.7. In Use flags.

5.4.8.7. Scaling of messages

Scaling of values may be necessary in order to get the precision of the values that
the application requires. It may also be necessary to take scaling into consideration
when commands are sent from the application.

There are two means to scale values in the gateway: global scaling and parameter

specific scaling.
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* Global scaling is done using the decimal place setting.

 Parameter specific scaling is done for analog values in the parameter specific
properties dialog.

To calculate the value on the SPA bus, use the following formula:

Profibus_Value
Decimal_place

SPA_Value =

(parameter scaling x 10

)

To calculate the value on Profibus, use the following formula:

Profibus_Value = SPA_Value x (parameter scaling x 10°°¢mal-Place )

The scaling factor is configurable when you select a signal of Indirect SPA message
type and click Edit. The default value is 1.

application when used in the gateway, otherwise the master will

ﬂ Scaling must be taken into account also in the Profibus master
handle scaled values instead of the real values.

Message priority

SPA Poll messages can be handled as prioritized messages, that is, they are polled
more frequently than other messages. The priority of SPA Poll messages can be
configured individually for each analog/digital input/output or a whole slave can be
prioritized.

Normally, all messages will be polled once every cycle regardless their priority.
Between each normal poll, a prioritized poll can be issued using a priority cycle. The
priority cycle only handles prioritized messages.

Messages can be prioritized as follows:

1. Select a signal and click the Edit button, or double-click on the signal.

2. A signal configuration dialog will pop up, in which you can select the Priority
check-box in the left corner.

3. Click OK. The priority will be indicated in the template signal list with the letter
P directly after the name of the signal. The letter N indicates normal priority,
that is the signal is not prioritized. The default is N.

To prioritize a whole slave, select Slave > Prioritize > On.

It is better to prioritize a group of signals, for example, an entire
ﬂ slave or all slaves’ / single slaves’ digital inputs or analog inputs.
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6.1.

Standard configuration templates

Module status word

When operating in cyclic mode, that is, polling values from the protection relay, the
module status word is transferred first in every message frame. The content of this
word includes the status of some important running conditions, as defined in Table
6.1.-1.

Table 6.1.-1 Module status word description

overflow

Bit [Name Description

0 |[Gateway mode 0 = Gateway operates in configuration mode.
1 = Gateway operates in application mode.

1 |Configuration status 0 = The configuration file is working properly.

1 = The configuration file has errors (CRC, incorrect setup detected...) or does not exist (first
start-up). For more information about the errors, see Section 8.4. Troubleshooting.

2 |Hardware status 0 = The gateway is working properly.

1 = Hardware failures have been detected in the gateway.

3 |SPA On-line (0) / 0 = Gateway is on-line. It communicates with the SPA slave device.

Off-line (1) 1 = Gateway is off-line. Communication with the SPA slave device is disconnected.

4 |SPA initialized (0)/ 0 = Configuration file has been initialized.

Initializing (1) 1 = Configuration file is being initialized.

5 |Configuration Warning 0 = No errors detected during initialization of the configuration file.

1 = Errors were found while initializing the configuration file. The warnings do NOT prevent
the gateway from its operation state. Or, errors were found when the gateway tried to read
SPA parameter that does not exist in the SPA slave. Check template documentation for the
list of required functions in the SPA slave.

The configuration warning bit is also raised upon a NACK message from the IED connected
to the SPA-ZC302. The IED sends the NACK message, for example, if the control operation
access is denied or an interlock situation. The configuration warning bit is not tied to a
certain write message operation, therefore a successful write operation does not clear it.
Reset of the configuration warning bit is not supported.

6 |- Not defined

7 |- Reserved

8 |- Reserved

9 |- Reserved

10 |Indirect SPA pending This bit informs the state of message flow between the gateway and SPA slave. When using
the Indirect SPA messaging interface, this bit informs that the current message is pending
and waits for a SPA response.

11 |Indirect SPA complete This bit informs the state of message flow between the gateway and SPA slave. When using
the Indirect SPA message interface, this bit informs that the current pending message is
complete.

12 |Indirect SPA error This bit informs the state of message flow between the gateway and SPA slave. When using
the Indirect SPA message interface, this bit informs that the current message response
contains errors.

13 |Reserved Bit used internally

14 |SPA slave lost events The status information of SPA slave devices indicates that events have been lost.

15 |SPA slave event buffer |Overflow. The status information of SPA slave devices indicates that an event buffer overflow

has occurred.
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application mode and SPA initializing bit is zero. Bit 3 must be zero
(SPA On-line). If bit 5 indicates a configuration warning, then some
of the data is invalid (unavailable). The unavailable items are
reported with OXF in the Profibus message. For valid process data,
the SPA device status (IRF) information should also indicate no
errors and slave status bit must be set ("1™ ) for all the connected
slaves. For more information, see Section 6.2. Slave status word.

ﬂ The process data is valid when the gateway mode bit indicates

Slave status word

A slave’s status word contains information about a maximum of 16 slaves. The first
bit represents the slave with the lowest SPA address. The second bit is the slave with
the second lowest address and so on. When the bit indicates 1, it means that the slave
is online and the data on profibus side is valid. In case of an event based data
updating, the device’s SPA event mask has to be open. This error situation cannot
be seen from the slave status bit.

based data. This error situation cannot be seen from the slave status
bit. If the parameters cannot be read from the SPA device, the value
OxFF, OXFFFF or OXFFFFFFFF according to the size of the data.

@ The device’s SPA event mask has to be open when updating event
[ ]

Usage and purpose of SPA protocol events

When a protection relay detects an exception in normal operation (such as a trip or
a restart of the relay) an event is generated and buffered inside the protection relay,
providing that the event mask has been set correctly. Events are identified on the
SPA protocol as E-codes, for example E50, which indicates that the protection relay
has restarted. These events can later be uploaded from the relay to a SPA protocol
master. See the protection relay manual for details on triggers events.

The SPA-ZC 302 gateway contains a SPA master that is capable of uploading this
information from the protection relay. When the polling of events feature is enabled
in the configuration template, the SPA master transfers the information to the
Profibus master as a changed state of the parameter in question.

event based data should be read only to one of the connected SPA
masters. The Profibus-DPV1/SPA gateway contains such a SPA
master.

@ If multiple SPA connections from a protection relay are used, the
[ ]

The event codes are also used in the gateway in a different way, such as to update
the measurement value of a binary input value. This feature is used in some standard
configurations concerning mainly start and trip information, and breaker state.

A single-bit and a double-bit indication uses SPA protocol events as presented in
Fig. 6.3.-1 .
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Fig. 6.3.-1 SPA protocol events structure

When the gateway goes on-line, the momentary value of a parameter is read into the
low nibble of the digital input. After this, the momentary value is updated when a
SPA protocol event is generated in the protection relay. This means that the Profibus
master always will have a valid momentary value for the parameter in question.

information, if a very fast double transition occurs between two SPA
poll cycles. If events are used, then all transitions are catched, but
they may be delayed.

@ If the data is not updated based on events, it is possible to lose
LJ

It is probable that the loss of a fast double transition is related to the speed of
Profibus DP. The faster the Profibus DP master polls its slaves, the less likely it is
that a double transition is lost.

The events that are supported in the standard configuration templates are listed in
the SPA code column of the cyclic signal table, directly after the SPA code that
provides the gateway with the initial momentary value.

6.4. Using indirect SPA messages

It is only possible to use indirect SPA messages in Profibus DP masters that support
Profibus DP version 1 or higher. The master must also be able to address a specific
slot and index. Some masters may require special configuration to meet the
requirements when using indirect SPA messages. It is the acyclic property defined
for version 1 that enables this kind of functionality. Because the indirect SPA
messages are not connected to any poll cycle, they can be used to define own SPA
messages that can be read or written any time by the Profibus DP version 1 master
configuration.

Typical SPA messages are defined for some of the configurations. Nothing prevents
the user from adding new, changing existing or even removing SPA messages from
the configuration. Therefore, the indirect SPA messages defined in the
configurations shall be considered to be a best guess of what might be needed when
using that particular configuration.

Indirect SPA messages are defined using the PCT, see Section 5.4.8.6. Indirect SPA
Messages. In the PCT, the indirect SPA message gets an index that is later used to
refer to that specific parameter. A maximum of 127 messages can be defined.
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After the configuration is downloaded and the gateway has started, the defined
indirect SPA message is used by writing its assigned number (8 bit) to Query slot 15
Index 5. The value of the 7th bit in the number shall be changed in order to trigger
the gateway to send the message to the SPA slave.

Example:

Assume that there is a defined indirect SPA message with number 1. When
writing value 0x81 to Query slot 15 Index 5, the gateway sends the message
to the SPA slave. Next time the value 0x1 shall be written into slot 15 Index
5 in order to trigger the operation.

Setting the static data to zero in the configuration enables the use of Indirect SPA
value, which means that the gateway uses the value in slot 15 index 6 in the SPA
command, see Section 5.4.8.6. Indirect SPA Messages.

Write the value (32 bit) to Query slot 15 Index 6 before triggering the sending. Keep
in mind that this value (and the static data value) is scaled in the same way as the
cyclic parameters values, see Section 5.4.8.7. Scaling of messages, for example, if
the decimal place is 1 and scaling value 1 is scaled to 0.1 on SPA bus.

It is recommended to check the module status after indirect SPA messages to ensure
that the message response indicates no errors.

The response to the sent indirect SPA message can be read from response slot 17.
The data is set up as follows:

SPA request status can be found in slot 17 index 0. The length of the SPA status is
two bytes. See the status code in Table 6.4.-1.

If the response from the SPA device contains data, for example the value of the
current measurement, it can be found in slot 17 index 1. The length of the data is four
bytes.

The status word in response slot 17 can have one of the following values, see Table
6.4.-1

Table 6.4.-1 Indirect SPA messages error table

Description Error Code Description

No Error 0x1000 No error has occurred

SPA Slave-Checksum Error 0x8000 SPA message contains a checksum error

SPA Slave-Busy 0x8001 SPA slave is busy

SPA Slave-Input Buffer Overflow |0x8002 SPA input buffer overflowed

SPA Slave-Msg too Complicated |0x8003 Message from the master is too
complicated for the slave

SPA Slave-Reserved High Lvl 0x8004 Reserved for higher level of
communication

SPA Slave-Syntax Error 0x8005 Syntax Error. Incorrect message type or
category etc.

SPA Slave-Missing data 0x8006 Slave does not contain all requested data
in the message

SPA Slave-Impossible Address 0x8007 Addressed data is impossible to write or
read

SPA Slave-Not Validated 0x8008 Data in write message not validated
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Table 6.4.-1 Indirect SPA messages error table (Continued)

SPA Slave-Unknown NACK 0x8009 Undefined negative acknowledgement
SPA GW-Checksum Error 0x8100 SPA slave response contained a checksum
error

SPA GW-Input Buffer Overflowed |0x8102 SPA slave response too big for GW input
buffer

SPA GW-Msg too Complicated 0x8103 SPA slave response too complicated for
the gateway

SPA GW-Syntax Error 0x8105 SPA slave response can not be interpreted
by gateway

SPA GW-Missing data 0x8106 SPA slave response is incomplete

SPA Network Timeout 0x8200 SPA message has timed out

SPA Network Response Pause 0x8201 SPA Response Pause time is violated

SPA Slave off-line 0x8202 SPA Slave is off-line why the message is
ignored

6.5. GSD file

For a Profibus device to be fully compliant with the Profibus specification, the
vendor must provide a GSD (Geréte Stamm Datei, Basic Profibus Device
Description) file for the Profibus slave device. A GSD file contains basic data about
the device, such as communication parameters, that make configuration and
commissioning of the device easier.

6.5.1. GSD file and standard configurations

The relation between the GSD file and the standard configuration templates is
logical. That is, there is no strict connection between the two entities. The main issue
is, however, that the size of the configuration of the gateway must match the size of
the module in use. This is because the module defines the size of the data block that
is copied from the Profibus slave to the master in each poll cycle, and if this size does
not match, the communication will not work properly.

6.5.2. Using GSD file

When you have selected, completed and downloaded the configuration of the
gateway, the Profibus master should be configured to accept the gateway device as
a part of the Profibus network.

Because different Profibus masters are configured by using different procedures, it
is strongly advised to consult the user documentation for the master in use. However,
all the masters are equipped with a mechanism for use with the GSD file, which is
provided by the vendor of the slave device.There are also masters using offset
calculations.

When the GSD file has been inserted into the system configuration, you can select
a number of modules for use. Which module should be used for which standard
configuration is documented in the GSD module section in each of the standard
configuration template descriptions.
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6.6. Standard configuration templates

There are available ready-made standard configuration templates designed for the
use of SPA-ZC 302 gateways. The templates can be combined to build up a
multislave configuration as long as they stay below the total size limit. For more
information about the templates, refer to the SPA-ZC 302 Standard Configuration
Templates manual. The manual is included in the SPA-ZC 302 configuration CD.
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SPA-ZC 302

7.1.

7.2.

Technical data
Interfaces

Profibus DP version 1 interface

* RS-485 twisted pair
* 9-pin female D-connector

SPA bus interface

» RS-232, RS-485 or TTL levels
* 9-pin female D-connector

Power supply

SPA-ZC 302
* Input voltage: 110 V...240 V AC/DC

 Qutput voltage (conf. with DIP switch 1.5): +8 V DC unregulated from pin 9

(RS-485, TTL)
 Supply current consumption: <80 mA

Table 7.2.-1 Environmental conditions

Specified ambient service temperature range -10...+55°C

Transport and storage temperature range -40...+70°C

Maximum relative humidity (without condenzation) 95%

Table 7.2.-2 Environmental tests

Dry heat test according to IEC 60068-2-2 +55°C

Dry cold test according to IEC 60068-2-1 -10°C

Damp heat test according to IEC 60068-2-30 RH > 93%, 55°C, 6 cycles
Degree of protection by enclosure of the device case according

to IEC 60529 IP20

Table 7.2.-3  Electromagnetic compatibility tests

The EMC immunity test level fulfils the requirements specified below

1 MHz burst disturbance test, |common mode 2.5kv
class Ill, IEC 60255-22-1 differential mode 10KV
Electrostatic discharge test, for contact discharge 6 kv
class 111, IEC 61000-4-2 and for air discharge 8 kV

IEC60255-22-2
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Table 7.2.-3

Electromagnetic compatibility tests (Continued)

Radio frequency interference
test

conducted, common mode 10V (rms),

IEC 61000-4-6 and IEC f =150 kHz...80 MHz
60255-22-6

radiated, amplitude- 10 V/m (rms),
modulated f=280...1000 MHz
IEC 61000-4-3 and IEC

60255-22-3

radiated, pulse-modulated
ENV 50204

10 V/m, f = 900 MHz

Fast transient disturbance test
IEC 60255-22-4 and
IEC 60255-22-5

power supply

4 kv

Surge immunity test
IEC 61000-4-5

power supply

4 kV, line to earth
2 kV, line to line

Power frequency (50 Hz)
magnetic field
IEC 61000-4-8

300 A/m continuous

Voltage dips and
short interruptions
IEC 61000-4-11

30%, 10 ms
60%, 100 ms
60%, 1000 ms
>90%, 5000 ms

Electromagnetic emission tests

conducted RF emission

EN 55011, class A

directive 73/23/EEC

EN 55011 and (mains terminal) IEC 60255-25
IEC 60255-25
radiated RF emission EN 55011, class A
IEC 60255-25
CE approval Complies with the EMC directive 89/336/EEC and the LV

Table 7.2.-4 Dimensions and weight

Type

Dimensions [mm]

Weight [g]

SPA-ZC 302

197 x 104 x 50

530




1IMRS755014 Profibus-DPV1/SPA Gateway SPA-ZC 302

Installation and Commissioning Manual

~
[ e

©]
]

T

——m

)T

302_dim_a

Fig. 7.2.-1 Dimensions of the SPA-ZC 302 module
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8.1.

8.2.

8.2.1.

Maintenance and service

General about service

If the SPA-ZC 302 module or part of it is found to be faulty, the normal service
operation is to replace the entire module. For more details, refer to the ordering
information.

Custom configurations

There may arise situations when no existing configuration fulfils the requirements
of the application. In these cases, our customer support organization offers service
by creating new standard configuration templates. The new configuration is then
included with the next release of the product CD as a standard configuration, if it is
also relevant to other users.

To be able to sufficiently prepare a service request, the following procedure should
be followed:

1. Look in the relevant protection relay manuals for SPA parameters that contain
information that is necessary for the application.

2. Contact customer support at ABB OY, Substation Automation and send in the
information.

3. Customer support will make an offer, based on the provided information.

4. If the offer is accepted, the configuration will be built, tested and documented.

The following data is required:

» What protection relay is to be supported (for example: REM543R or several
relays)

» SPA parameter data of the signals wanted (for example: 4806)

« Description of the signal (For example: Cooling time in seconds)

 The order of the parameters, in case it is important

Limitations
There are some limitations that affect the way the standard configurations are made:

244 bytes of input, 244 bytes of output or totally 416 bytes of data bandwidth is
available for input or output. The reason for the limitations is limits in the
Profibus protocol specification and the implementation of it. Consequence of this
limitation is that it is possible to transfer only a certain amount of cyclical
parameter data over Profibus from each device. It can be assumed, as a guideline,
that each analog data need four bytes, and each digital data one byte of data
bandwidth.

value in PCT is limited to 240. A warning message is displayed in

ﬂ When building the multislave configurations, the total template size
PCT if the limit is exceeded.

 The larger the number of signals, the longer will the update cycle be.
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8.3.

8.3.1.

Self-diagnosis

LED indicators
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Fig.8.3.1.-1  Profibus-DPV1 LED indicators

See Table 8.3.1-1 for the description of the Profibus LED indicators pictured in
Fig. 8.3.1.-1.

Table 8.3.1-1 Profibus-DPV1 LED indicator

LED no |Description Colour |State Indicates
On A DPV1 request is currently being executed.
1 Acyclic Green Off No Power to the module.
Traffic No DPV1 request is currently being executed.
On Bus is on-line and data exchange is possible.
2 Fieldbus Green Off No power to the module.
ON-line Bus is not on-line.
Flashing 1 Hz |Clear mode. The Profibus master has initiated a clear command.
On Bus is off-line.
3 Fieldbus Red Off No power to the module.
OFF-line Bus is NOT off-line
Off No power to the module.
No diagnostics is present.
4 Fieldbus Red Flashing 1 Hz |Error in configuration data.
Diagnostics Flashing 2 Hz |Error in parameter data.

Flashing 4 Hz |Error in initialising of the Profibus communication ASIC.

62




1MRS755014

Profibus-DPV1/SPA Gateway

SPA-ZC 302

Installation and Commissioning Manual

M
=t | |OO0COCNBAR0 1
SPA STATUS
A—r
o SPA_LED_a
Fig. 8.3.1.-2  SPA LED indicators
See Table 8.3.1-2 for the description of the Profibus LED indicators pictured in
Fig. 8.3.1.-2..
Table 8.3.1-2 SPA LED indicator description
LED no |Description Colour |State Indicates
Off No power to the gateway.
Green |Flashing 1 Hz Power ON. Running in configuration mode.
1 Module Status On Power ON. Running in application mode.
Flashing 1 Hz Configuration error. Test of the onboard configuration file failed
Red (gateway not operational).
On Hardware error (Flash, SRAM, ABS).
Off SPA/Cfg Communication Idle.

Flashing irregular

Serial Message Transmission when in Application mode (Until SPA

Green goes on-line) and when in configuration mode.
SPA On SPA Network on-line.
2 Communication Serial message reception error when in both application and
Flashing irregular |configuration mode
Status Red (framing, parity, CRC error etc.).
On No SPA slave attached or cabling problem (SPA Network Offline).
8.4. Troubleshooting
When troubleshooting the gateway, first check the LED indicators described in
Section 8.3. Self-diagnosis. If there is a LED flashing, a coarse error can be located
through the flashing pattern of the LED.
8.4.1. Gateway diagnostics

Detailed information about the error may be available in the diagnostics that can be
uploaded from the gateway. For details about uploading, see Section 5.4.2.3. Upload
diagnostics.
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Fig.8.4.1.-1  Diagnostics dialog
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The Diagnostics dialog is divided in four different sections: 1. Configuration,

2. Module, 3. Event Buffer and 4. SPA message statistics:

1. Configuration

File revision

Download date

Status
Error type

Problem ch
Problem cat
Problem Dno

Revision of the configuration file used

Date when the configuration has been downloaded

Status of the configuration

An error type number if an error was detected at
initialization of the device, see Table 8.4.1-1 .

SPA channel number of the configuration problem

SPA category of the configuration problem

SPA parameter name of the configuration problem
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Table 8.4.1-1 Configuration error types

Error Type

Description

Configuration OK

No problem detected in the configuration file.

Configuration Empty

The gateway was not able to locate any configuration.

Configuration valid, but not
initialised

Check that the relay is connected and SPA addresses and
communication speed in the relay are correct.

CRC Failure

The gateway was not able to verify the CRC of the
configuration file.

Unsupported Baudrate

The gateway was not able to use the configured baudrate.

Unsupported Reply Timeout

The gateway was not able to use the configured Reply
Timeout.

Unsupported Idle Time

The gateway is not able to use the configured Idle Time.

Unsupported Retry Count

The gateway is not able to use the configured Retry Count.

Unsupported PDP Default
Address

The gateway is not able to use the configured Profibus
Default Address.

Unsupported Decimal Place

The gateway is not able to use the configured Decimal
Place.

Analog Input Error?)

Error in one of the Analog Input settings.

Digital Input Error?)

Error in one of the Digital Input settings.

Analog Output Error?)

Error in one of the Analog Output settings.

Digital Output Error?)

Error in one of the Digital Output settings.

Indirect SPA Errord)

Error in one of the Indirect SPA settings.

DThese error codes are followed by more data in the diagnostics fields, such as SPA Channel, SPA Type
and SPA Dno (Parameter No) for easier location of the trouble spot. For all other error situations,

these fields will be set to zero.

2. Event Buffer section

Slv Slave address from which the event has been read
Sec Seconds when the event occurred

Msec Milliseconds when the event occurred

Ch Communication channel on which the event occurred
Type Type of event that occurred

Nr Event number

Val Value of the event

3. Module section

SPA Gateway Time Set time in the gateway

Module Status Word Status of the gateway. This word is sent to the master as
the first word in each input data block. The definition of
the bits is described in Section 6.1. Module status word.

4. SPA messages statistics section

Transmitted Number of SPA messages transmitted

Correct Number of correctly formed SPA messages
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NACK’s received Number of NACK (Negative Acknowledgement)
responses received from the SPA slave

Checksum errors Number of checksum errors detected

Timeout occurrences Number of timeout occurrences. The timeout occurrences
counter is increased when the SPA slave does not answer
to the gateway in the time specified in “SPA reply
timeout™. If you notice this error, try to increase the SPA
reply timeout.

Off-line occurrences Number of times communication between the SPA slave
and the gateway has been lost

On-line occurrences Number of times communication between the SPA slave
and the gateway has been established

Events received Number of events received

Event lost occurrences  Number of event lost occurrences. The event lost counter
is increased when the protection relay reports that it has
lost events for example due to a reset.

Event buffer overflows Number of times the event buffer has overflowed. The
event buffer overflow counter is increased when the
protection relay reports that an event buffer overflow has
occurred. If this occurs often, check the protection relays
event mask settings first, and if no errors can be found
there, try to decrease the global poll interval setting, see
Section 5.4.7.1. SPA configuration.

Poll cycle time Time span in which the polled SPA parameters are
updated.

8.4.2. Communication errors between SPA-ZC 302 and SPA slave

66

If there are indications of communication errors between SPA-ZC 302 and the SPA
slave, you can try to change the "SPA Reply Timeout", "SPA Idle Time" and "SPA
Com Retry Count" parameters. The default parameters should work without any
problems with most of the SPA slave devices. If you notice SPA communication
failures when checking the Diagnostic dialog of PCT, then following guidelines
should be followed when changing the parameters:

 Usually, the SPA communication errors are caused by the hardware. Therefore,
start by checking all cabling and hardware settings of the SPA slave and SPA-ZC
302 device. If several slaves are connected, check the SPA loop and that the
connected converters are set correctly.

« If hardware setting or cabling errors are not found, try to increase "SPA Reply
Timeout" and "SPA Idle Time" into their maximum values.

« If the communication is now working properly:

« Search for the minimum value for the "SPA ldle Time". A value below default
value is not recommended.

» When the minimum value for the "SPA Idle Time" is found, you can repeat the
same process for the SPA Reply Timeout. A value below default value is not
recommended.
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« If the communication is still not working, try to increase the "SPA Com Retry
Count". This might be an indication of a hardware error in the cable or in the
devices. Contact your ABB representative.
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